RSUDP not writing miniSEED

Hello Raspberry shake community!

Currently i have 1 RS4D set up and its working perfectly but i’m only having some issues with RSUDP.
I’m sending over the data from the raspberry shake to a VM running Debian 11, installed RSUDP as in the tutorial provided by the creator, and it works fine, except for the miniSEED not writing.

It seems that it isn’t a permissions error, whenever an event is triggered, it makes screenshots just fine, and stores it in the right place, but the miniSEED just wont write at all

in the config file I’ve set the write enabled to true and all channels

"settings": {
    "port": 8888,
    "station": "AM.RF2A7.00.EH",
    "output_dir": "/etc/rsudp/",
    "debug": true},
"printdata": {
    "enabled": false},
"write": {
    "enabled": true,
    "channels": ["all"]},
"plot": {
    "enabled": true,
    "duration": 30,
    "spectrogram": true,
    "fullscreen": false,
    "kiosk": false,
    "eq_screenshots": false,
    "channels": ["HZ", "HDF"],
    "deconvolve": true,
    "units": "CHAN"},

or is it prehaps not possible to get miniSEED out of the RSUDP Software?

Hello IFTech, welcome to the community!

Yes, as you have imagined, RSUDP is capable of writing a miniSEED file from the data that it receives in real time from the connected Shake.

Since you have already checked for permissions (which is the first thing that I usually recommend), the element that you have to change in your config file is the following:

"write": {
    "enabled": true,
    "channels": "all"},

That is, to remove the square brackets in the channel sub-category. This should, after restarting RSUDP, make the miniSEED writer start properly, and you should see files appearing after a bit in the indicated folder.

Hello Stormchaser,

Thanks for your reply, I’ve changed the settings in the .json, but unfortunately I’m still not getting any miniSEED files. is there anything else i could try to fix this?
the only warning I’m getting from RSUDP is that the station name is wrong, but i don’t think that should be an issue.

I’ve tried running RSUDP as root as well, but I’m getting a different error

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'

i also noticed after letting the RSUDP run for a while (like 2 to 5 minutes) as a normal user and root, it seems to get stuck and not respond and i have to close the monitor to start the unix script again.

do you have any suggestions where i could check to fix there problems?

With kind regards,
IF Tech

Hello IF Tech,

I have tried to replicate your issue with my two RSUDP installations but I wasn’t able to. I would then suggest wiping the system clean of your current installation and then re-install from scratch, to see if this solves the miniSEED writing issue.

The fact that the software gets ‘stuck’ could also be a sign of something that has not gone right with the original installation. To compare, I have installed mine on a Raspberry Pi, and even after weeks, it is working as expected. It is possible that the issue is caused by the VM, and maybe it can be solved by increasing the resources assigned to this environment.

Hello Stormchaser,

I’ve prepared a new VM with a different linux distro (Ubuntu) and with double the resources, (4 vCPU’s and 8GB RAM), and only installed RSUDP, and changed the configuration so it would write the data to the correct location

But unfortunately I’m having the same issue’s as before.

is the RSUPD software not compatible with VM’s perhaps?

With kind regards,
IF Tech