Rsudp hangs up on windows 10 machine when directly connected to shake boom via ethernet

I’m trying to use my shake to collect data during a lab demonstration. We’ll be outside, away from Wi-Fi networks, and I’d like to use RSUDP to show the data being collected on a Shake Boom while we are outside.
I have RSUDP running when the shake and my windows laptop are both on the same network, and it looks perfect.
I’m also able to share my windows internet connection with the shake and interact with it via ssh and through the rs.local interface while the shake is connected directly to my laptop via ethernet.
Unfortunately, when I try to use RSUDP in this direct ethernet connection setup, it hangs on the message Waiting for UDP data on port 8888...
I’ve tried using my laptop’s external IP and local network IP, and I’ve tried turning off windows defender firewalls temporarily just to make sure that isn’t a problem.
I’m not super savvy with networking, am I missing something elementary here?
Thanks in advance for any light you might be able to shed!
RSH.R0B30.2022-10-05T03_42_37.logs.tar (2.8 MB)

1 Like

Hello kbrill,

Thank you for the logs. Nothing looks out of place, so I can say that your Shake is in good health, which is always good news! Also happy to hear that RSUDP is performing well!

Regarding the connection issue, it is possible that, when in direct connection mode, you have to adjust (if you haven’t already done it) the IP range to the one that the Shakes are programmed to look for. These two pages on our manual can be of use:

Once this has been set, you can update the Shake DATACAST tab with the new local IP address of the target computer (in this case, your laptop) and RSUDP should now be able to connect and display live data from the Shake itself.

It is also possible that, albeit turning of the firewalls, you will need to add an exception for data transmission for port 8888. Sometimes they can work strangely like that.

Changing the IP on the laptop ethernet connection did it! After changing the IP on the laptop’s Ethernet connection to, I saw a message from the Windows Defender Firewall that wasn’t popping up before asking if I wanted to allow the connection, and after accepting, everything is working great.

Thanks so much for the reply!


Hello kbrill,

happy to hear that, and glad that I could be of help!

I hope that your demonstration will go splendidly!