RSUDP error while running

Im running rsudp on a Rpi 3B+ that recieves data from a shake, it starts without any problem, but it runs for maybe 5-10 minutes and then will throw an error, either “free(): double free detected in tcache2” or “corrupted size vs. prev_size ins fastbins” and the abort the program.

Does anyone know why this happens, has had the same error pop up and/or knows how to fix this?

Hello Matiro,

These errors appear to be related to some kind of memory issue. In particular:

  1. free(): double free detected in tcache2 indicates that a piece of memory was attempted to be freed twice
  2. corrupted size vs. prev_size ins fastbins indicates instead another instance of memory corruption

I never had these pop up while my PI3B+ RSUDP was running, so I cannot offer more precise insight. You could try to lower the amount of time of plotted trace (with the "duration": parameter in rsudp_settings.json) to 30-60 seconds instead of the default 90, this will lower the memory requirements.

1 Like

Thank you very much for the suggestions,
I tried yesterday to run it without the plotting function and till now no errors, i will try to lower these values and see if i can still plot.