Rsudp Download failure

I seem to have hit a road block in downloading the rsudp software. I followed along with the instructional video, downloaded GIT and made it all the way to the step in the screenshot below. The ‘matplotlib’ file seems to be the hold up. Any suggestions?

Screen Shot 2021-12-07 at 1.43.34 PM|672x500

Hello Paul,

Thank you for reporting this to us!
I will try to replicate this issue with my conda environment to see how it can be corrected.

In the meanwhile, from the command line, you can install the matplotlib version it asks for with this command:

conda install matplotlib=3.2.0

or, if it still doesn’t work, you can go back one version with this:

conda install matplotlib=3.1.3


conda install matplotlib=3.1.0

This should help in bypassing the error and the installation should continue as normal.

Thanks for the reply and for looking into the issue. Unfortunately, those commands don’t work either. When I enter the command it says [command not found: conda] [Could not create a new process and open a pseudo-tty.] I presume I’m missing something there?

There’s no problem at all, I am here for this too.

It appears strange that the error [command not found: conda] would show up since we are operating in an Anaconda environment.

My advice would be to completely erase this environment and all the files associated with it, and to create another one from scratch, so as to see if the problem was created by some corrupted and/or missing files in the current conda env.

Hi again! So I deleted the miniconda3 and rsudp files from my home drive and went through the process again using the git clone and unix-install command. Still had the same problem where rsudp failed to download because of the missing matplotlib. Does it matter that my home drive has “miniconda3” and the command is looking for “conda”? A bit new to terminal so I’m basing my experience thus far off of the youtube setup video.

Hello again!

It shouldn’t cause this much difference, but since miniconda is a somewhat less complete environment than anaconda and it requires that every package that is needed to be installed manually.

I would advise you to install Anaconda on your system, if you can, so that the installation will provide more basic modules. As per the original documentation, here: Downloading conda — conda 4.11.0.post8+f60f0f16 documentation these are the differences between the two systems:

Anaconda or Miniconda?
Choose Anaconda if you:

  • Are new to conda or Python.

  • Like the convenience of having Python and over 1,500 scientific packages automatically installed at once.

  • Have the time and disk space—a few minutes and 3 GB.

  • Do not want to individually install each of the packages you want to use.

  • Wish to use a curated and vetted set of packages.

Choose Miniconda if you:

  • Do not mind installing each of the packages you want to use individually.

  • Do not have time or disk space to install over 1,500 packages at once.

  • Want fast access to Python and the conda commands and you wish to sort out the other programs later.

Awesome, thanks. To clarify, I’d download the anaconda software and then run the rsudp install commands like before?

No problem at all!

Yes, you can download the Anaconda software, install it, and then execute the commands to install RSUDP like before. I have done it in this way and there were no issues at all.

Greetings! Alas, the same error remains. I successfully downloaded anaconda and can see the file in my home, but when I run the rsudp install command from github I still get the same error with the matplotlib. I have attached my home folder just to be sure that it looks normal. Should the script still install miniconda if I already have anaconda downloaded? If you have any other suggestions I’d love to hear otherwise I’ll pass on rsudp if its not in the cards and just use the dataview app on the web. Thanks for your time!

Hello again!

I’m honestly baffled by this issue, because I tried to reinstall RSUDP in a new environment with Anaconda, and the installation went fine.

I wasn’t able, thus, to recreate your error, so I’m not sure where the problem is with your environment. The script should find Anaconda, and then proceed from there. If is not finding it, then possibly there are issues with the global paths and variables, and they have to be adjusted before trying to install RSUDP.

Here’s a link on how to do it, but things become a bit technical: How to setup Anaconda path to environment variable ? - GeeksforGeeks

As an alternative, DataView (which is constantly being updated) will provide the same service, down to the live view with both waveforms and spectrograms.

No problem at all!

Understood. Yea not sure what it is either. I am part of a school system so perhaps that is interfering. I’ll just use the dataview. No harm! Thanks, again, for you help though. Much appreciated.

1 Like

It is no problem at all!

I’m sorry that we were not able to find the issue causing rsudp to not install properly, but there could be paths that have to be adjusted since the computer is in a school environment. These systems, as I’m sure you know, are set in different ways compared to normal usage PCs.

We will be improving DataView more and more in the coming months, so I hope you will be satisfied with that tool!

Resurrecting an old thread … I tried to install rsudp on my Almalinux (Centos 8 clone) system, and hit exactly the same problem. It looks to me that it has dependencies on an old version of matplotlib (or perhaps that lib no longer exists?).

I did submit an issue report on github, but no response yet.

What I see (tried three times):

Appending sourcing line to bashrc…
Activating conda…
No /home/rsudp/.condarc file exists. Creating…
Found conda-forge channel in /home/rsudp/.condarc
Creating and installing rsudp conda environment…
Collecting package metadata (current_repodata.json): done
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed

PackagesNotFoundError: The following packages are not available from current channels:

  • matplotlib’[version=’<3.2’]

Current channels:

To search for alternate channels that may provide the conda package you’re
looking for, navigate to

and use the search bar at the top of the page.

ERROR: rsudp failed to install.

Something went wrong.
Check the error output and try again.

Hello PhilipPeake,

From what you have indicated, it seems that the package matplotlib with version <3.2 is missing from your current system, and the RSUDP installer is not able to find it and thus proceed with the installation itself.

You can manually try to install it with the commands I have listed in this comment: Rsudp Download failure - #2 by Stormchaser

Remember that you have to be in an activated conda environment to be able to execute them. This is the conda reference documentation for this: Managing environments — conda 4.11.0.post37+c75b4b561 documentation

Well that didn’t work. I ran the conda command to install, and it worked, tried re-running the istall script ang had the same error. Tried the conda install again, said it was already installed.

I don’t have the time or inclination to learn whatever conda is. The install script should work…