Rsudp alert does not sound

I have enabled alerts in rsudp_settings.json and installed ffmpeg, but there is no sound when alerting.
This is a test video I recorded, and there is no alert sound on my laptop too.

Hello Akari,

Thank you very much for the video. In the RSUDP folder there should be a log file in the following location:


Could you please replicate the issue with the not-playing sound one more time, and then send this log file to me here? We will be able to see if there is something stopping the action from being executed, or if the problem is connected to something else.

Thank you.

Here is the log.
rsudp.log (2.3 KB)

Thank you Akari,

From it, everything seems in place, and there are no reported errors on why the sound is not being played. I tried to replicate the issue, but I can hear the doorbell alert.

Have you tried to launch RSUDP with administrator privileges? We have had instances in the past where some functionalities of the program didn’t work if launched normally.

I run rsudp with administrator privileges and there is still no alert sound.

Someone help? :frowning:

Hello Akari,

I have forwarded the issue to our RSUDP developer team, and they are looking into it. It is being a bit hard because we cannot reproduce the problem, and we get a sound when there is an event, but we will try our best.

I will give you an update as soon as I have news.

OK, thanks.
In addition, can you add band-pass filter option for the live data plot?
And the performance of the live data plot is very bad, it uses a lot of cpu.


I have set alert in rsudp_settings.json but no sound same as Akari user.
I have installed FFmpeg already and tried to run with administrator privileges but still no sound.

Best regard
Jugkrit Sringamphong

rsudp.log (99.5 KB)

Hello Jugkrit,

Could you also please attach your configuration file? Also, are you able to play the doorbell sound normally, and via FFmpeg?

Thank you.