RS4D V13 (Factory Sealed) Wifi credentials not going through

When i try entering my Wifi details and password and hit “Test Wifi” It infinitely loops on Confirming your WIFI Credentials, with it also going offline, meaning you have to manually unplug it from the wall. If anyone has an idea or it may need a replacement, please let me know! Thanks

1 Like

Hello Xtremeo,

The bug you are describing has popped up in the past for some users, and I think that a manual approach would suit this situation best. These issues are sometimes caused by communication problems between your modem/router and the Shake rs.local/ interface cause the WiFi bug you are experiencing.

Could you please SSH into the Shake (instructions here: How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake ), execute the following two commands:

  1. cat /etc/dhcpcd.conf
  2. cat /etc/resolv.conf

and post their output here (both copy/paste or a screenshot are great)?

Thank you!

1 Like

Heres the output it gave me, note the last output with the ip address was outputted 2 times.

1 Like

Seems the problem has resolved itself when connecting to a new router/modem. It’s possible that my already connected RS1D is the cause. But for now, its working :slight_smile: The fix would be nice to have though in case i may need to switch them or finally put them into one wifi router altogether.

1 Like

Hello Xtremeo,

Firstly, great to hear that your issue has been solved. I saw the event your Shake recorded in the other topic, so everything is working fine.

Absolutely, I agreee! This is the entire manual procedure we recommend to address this particular WiFi connection problem.

I suggest you proceed through the following list to see if this solves your situation:

  1. Please do the following first, to reset the Shake configuration to its default status:

Please open again the dhcpcd.conf file with

sudo nano /etc/dhcpcd.conf

Delete all the lines that start with static, if present (as is this case), thus leaving only interface eth0. If the line interface eth0 is not present, then add it (not this case, but a useful general reminder). Do not modify anything else.

Then do:

sudo service dhcpcd restart

to make sure those changes took hold and then check the output file with

nano /etc/resolv.conf

What we have done is temporarily reset the Shake IP interface to its original setup. This should renew the configuration and possibly, solve your connectivity issue. If the Shake still doesn’t connect after this last command, try rebooting it again.

  1. Follow the instructions on this page on our manual: How to configure Wifi and USB wifi dongles from command-line — Instructions on Setting Up Your Raspberry Shake . The operations are very similar to the ones you have done for point 1), so they will be familiar. Once done, your Shake should be able to connect via WiFi and you can check again if it is transmitting live data.

In this way, you’ll be able to configure the WiFi connection from scratch. For anything else, I remain available.

1 Like