RS3D not connecting to router

I have an RS3D. After it arrived I started it once without internet access but could see it on a computer with an Ethernet cable and reset the password. It was clearly working.
Then at home, I set it up and powered up. After 7 minutes I remembered to connect the Ethernet cable to my DSL router, and I could see it with the Web interface, and it was assigned an address by my router. After 3 days I could see the SD was filling up so I did a shutdown from the Web page (configuration page showed system 0.15 before shutdown).

I ordered a USB drive to hold the data so I wouldn’t fill up the SSD.
This week I installed the USB following the directions and it appeared to be successful. The system had updated to 0.18. I did a shutdown and set up in my basement. Once again I neglected to plug in the Ethernet cable before powering up. I did a few minutes later, but this time other computers on my home network cannot see the RS3D and the web page interface in Chrome will not load. My router has a list of all the computers that have connected in the past and the RS3D shows as disconnected. For the lights:
The Pi board shows red solid. There is no green light at all
The Shake board shows blue solid.
The Ethernet port shows orange solid and the green light flashes once every few seconds (about as often as the led for that port flashes on my router).
I tried rebooting my router - no change.
I regret that I have no logs for you, nor can I do a proper shutdown because the web front end will not load. I am wary of pulling the power, knowing that it can damage the SSD. I had not yet started data forwarding (perhaps unfortunate in this situation) so there isn’t any station yet for you to check.

Do you have suggestions for regaining contact with/control of my RS3D? And if something I did caused this problem, how can I avoid it in the future? Thank you!


Hello Ken, welcome to the community!

Firstly, thank you for the extensive explanation you’ve given us and the details of the steps you’ve undertaken while using the Shake for the first times.

The first thing that comes to mind, if you haven’t already tried it: can you check that the LAN cable in your basement is properly working and connected to your local network using another device, for example, a laptop? In this way, if the cable works, we can exclude that variable.

The absence of green light is a concern. These are the basics on how it should work:

If only the red PWR LED is active, and there is no flashing, then the Pi is receiving power, but there is no readable boot instruction on the SD card (if present).

When booting from an SD card, the Raspberry Pi’s green ACT light should have an irregular blink. However, it can blink in a more regulated manner to indicate a problem (I am putting this list here in case you did notice these unusual flashing patterns):

  • 3 flashes: starting files not found
  • 4 flashes: starting files cannot launch, so it’s probably corrupted. Alternatively, the card is not correctly inserted, or card slot is not working.
  • 7 flashes: kernel not found
  • 8 flashes: SDRAM not recognized. In this case, your SDRAM is probably damaged, or the bootcode or starting files are unreadable.

As of now I don’t know exactly what happened with the Shake itself, so let’s take this step by step to reach that conclusion.

I should have guessed to check the Ethernet cable myself, as it is a new, longer one than before. I find that it works fine just now when I use it to connect a laptop - it sees the router and can connect to the internet.

I checked again with a mirror and a flashlight (my basement is a bit dark in that corner), and the lights are as I reported. If the green ACT flashes you refer to happen during startup, I did not get to see them as I was in another room. I’m beginning to think it would be best for me always to be where I can see the Shake when starting up and powering down. I cannot rule out that my last shutdown before attempting this failed startup may have gone wrong, which I know can be bad for the SD card - if you can see the unit you would clearly know when the lights have gone out.

I appreciate your patient advice and am ready to check or try anything else you can suggest.


Perfect, we now can check the LAN cable variable out since it works fine.

The green LED should be visibile during startup, but it should also be blinking every now and then (around 2 to 5 seconds) while the Shake is working. If this is not happening, then there are some problems with the microSD card.

It’s absolutely no problem at all, we are here for this. What I can advise you now is to shut down the Shake, even if you have to pull the plug, because unless we can access it there’s nothing we can do from the outside.

So please shut down the Shake, then restart your modem/router (to have a completely clean slate), wait for a couple of minutes after the router has completed its process, and then with the LAN cable already in place, start the Shake up again, and see if it will be recognized and seen on the local network.

If we’re lucky, everything will be ok, otherwise, we will look at other options.

I went through these steps as suggested. I made sure I was standing by the shake, and I had a laptop running nearby showing the configuration of the router and its connections. As soon as I powered up the green light on the R Pi flashed on twice very quickly. Then a few seconds later it gave a series of regular flashes at about 1/ per second. I counted 27. Then off; finally I turned away to make notes; when I looked back perhaps 30 or 60 seconds later, the regular 1/second flashes were happening again. There were 9 or 10 that I saw; I didn’t think to start counting right away. There may have been more before I started watching again. At no time after the very first two flashes did it give irregular flashes one would associate with CPU or other activity. The Shake never appeared on the router configuration.

I should add that this is all good experience for me. I want to set up this Shake in a nearby school for a time later this year. The students can learn about seismology but also think about people and places elsewhere in the world, which is a good experience for them. So knowing what might go wrong and how to diagnose it is useful for me. Best to learn about it now!

I have already looked up where I can get 8 GB microSD of MLC grade and will order several, in case that is something I have to replace now or later…I won’t be surprised if that is the next step. It will be a few days before I can try that if needed.

A fantastic report, thank you very much!

It is indeed a good experience, especially for an educational output like the one that can be reached in a school. And if something similar will arise, then you can ‘show off’ a bit of your Shake knowledge!

Going back to the issue, the boot-up process seems fine, but the fact that the Shake continues to not appear there is really baffling. At this point, as you have already correctly surmised, the next step would be burning again the Shake OS on a new microSD card.

Here are the details on which microSD cards to use (MLC is fine):

While here is the process to prepare the microSD and burn the new Shake OS image on it:

  1. Please take the microSD card you have and format it before burning the new Shake OS image.
  2. Make sure, when you format it, that the shown capacity is the maximum (i.e. if the SD card is 16GB, then the capacity should be near or equal to that value). This is to check that no partitions have been involuntarily and erroneously created.
  3. Take care to format the SD card in a FAT32 File System (or exFAT if the SD card is 64GB or larger)
  4. Please download the new Shake OS image from here:
  5. And follow the microSD burning instructions from here:

If this does work, then the Shake will boot up again fine and you should be able to see the details in the rs.local page.

No problem at all if you need time, we will wait here for news on your side.