RS module is possibly faulty

I have tried my RS1D module on two different Raspberry Pi 4B+ computers. I am using a newly mounted RS image. I have also tried the factory loaded RS image that came with my RS1D module. Neither one will start the Shake program. The blue light comes on. The lights on the RPi show a red light with a green light that blinks 7 times rapidly, repeatedly. I have waited for as long as an hour… RS local does not start. I have also used the IP address with no results. I have used the RS1D module for over a year and it worked fine until recently. I suspect a faulty RS1D module. Please advise.

1 Like

Hello Jkgarman,

Regarding the Raspberry Pi 4 boards, we only support the following for the Raspberry Shake 1D (Technical Specifications), and the 4B+ model is not currently on our list:

However, if you want to be sure about other Pi boards you may have and don’t know it yet, you can check their revision code by starting up the Pi using a microSD card with the latest RPi OS installed and executing the pinout command.

If it’s not available, you can execute these three steps to run it from the command line:

  1. sudo apt update
  2. sudo apt install python3-gpiozero
  3. pinout

In the output, you will find a line starting with Revision that will provide you with a hexadecimal string to compare with the image I posted above.

This will help determine whether the source of the issue is a Pi board that is currently unsupported or if the RS1D module is no longer working.

Thank you.