Rs.local wireless connection keeps getting dropped

I continue to have issues maintaining my wireless connection to my RS3D. I have several wireless devices in my home that are not dropping their connections.
This seems very specific to the Shake.

The Shake is working fine and appears to be transmitting its data okay also.
What my understanding is, is that rs.local is just to allow me to access my Shake but is independent of the Shake capturing and transmitting data.

Are there things I can check or troubleshoot to see if I can correct the connection loss?
Really the problem is two issues.

  1. rs.local wireless dropping out
  2. once wireless connection is dropped, it may be hours before I can reestablish wireless connection via rs.local

Hello yellowfin1,

Yes, rs.local is a front-end interface that helps you with the Shake configuration and provides you with a tool to avoid having to modify text files one by one to set up everything.

Have you tried to connect to the Shake via using its IP address instead of typing rs.local/ in the browser address bar? In some local networks it seems that this may be a stable way to connect to the unit.

I use it regularly in my to check on all the Shakes that I have, and I haven’t met this issue (yet).

I tried that early on. Made no difference.
When you logon on to rs.local, what are you accessing to identify which model Pi is being used?
Is it purely informational or are you using it in some fashion?
Both Pi 4’s I’ve used show unknown device or unknow model. Whatever you have as error text, the rs.local config page is unable to identify 2 different Pi 4B’s

This is strange, but it may be that these are very recently released board models and we yet need to add them to our list of recognized devices.

Or, this may be a sign of something more serious going on, and we wil need to investigate it more deeply.

Could you please provide the logs for both the two Pi4 boards that are not recognized by our Shake OS so that I can pass them to our software team and they can take a look at them? We may be able to include this fix in the coming Shake OS releases, so that you and other users in the future will not have this problem.

Thank you for your cooperation!

I’ll see if I can download the two sets of logs but I’m rolling back to P3 that I have been experimening with and going to see how that goes.
I’ve messed around with P’s alot, primarily Pi4 all with the general connection setup.
Never had this level of problem connecting.

Wayne Wells

I have determined that problem lies with router. In my experience with Pi computers their IP address has always been static. This new router seems to be changing router assignments on the fly. I am waiting on Netgear tech support to call me back to try and resolve this issue.

Not sure if you are aware but I believe Raspberry Pi just recently came out and made it official that the Pi OS is 64 bit. Link Below.

I was looking at the file dates on your OS and some are pretty old.

I was concerned that it was the 64 bit pi hardware conflicting with your software but figured out it is router.


I had a period where my Shake was down as I worked through solving a wifi dead zone. I think I have that resolved but ended up providing the Shake with a dedicated access point.

I got a couple of email “We miss you” type emails which were triggered by length of time system was down.
Should Shake just come back under old call sign or is the old call sign been set to offline or similar.

1 Like

Hello yellowfin1,

The Shake will come back under its old ID unless you have changed its Pi board (the naming rules are listed here: Raspberry Shake Station Naming Convention — Instructions on Setting Up Your Raspberry Shake).

Otherwise, it can stay disconnected for weeks or months, but as soon as it is back online, it will operate again under its old ID.