RS&BOOM :: connected to server, not showing up on station view

Hi shaker community and RS team,

I’m a novice in the forum and in sensor technologies and had a difficult start to get my RS&BOOM (AM.R72A4) running in the first place as it is located at a university and behind complicated firewall settings. Our IT team however solved the connect-to-server issue I had with the RS&BOOM. Everything shows as connect and on (green) in the rs.local overview.

NOW, a new problem, my RS&BOOM does still not show up on the Station View, although being shown as online (yet without streaming or showing any data) in the MyShake view on Shakenet. My phone app doesn’t find the RS&BOOM either. So something seems to be wrong with the machine or on the RS end, I imagine.

I’ve tried restarting etc. more than twice. Last week, the same situation, but the RS&BOOM showed up on station view, even though not transmitting any (or showing any) data. I waited 24 hours for the data and RS&BOOM to show up, as I found was one of the comments in one of the forum postings. After 24 hours, the RS&BOOM was completely gone and didn’T show up on StationView or elswhere on the Shakenet platform.

I’m attaching the log-files from this morning.RSH.R72A4.2022-04-27T09_07_01.logs.tar (2.6 MB)


1 Like

and here are the log-files from last week, when the RS&BOOM briefly showed up on StationView, even if not streaming any data, it seemed to react to external stimuli (as I jumped next to the sensor) as the heightened vibrational activity was reflected in the color of the station changing on station view).

RSH.R72A4.2022-04-21T12_28_46.logs.tar (2.0 MB)

1 Like

Quite strange … There is some data showing this morning (my time):

Looking a bit closer:

and closer still at those signals:

1 Like

I saw similar minute data bursts when I rebooted last week and had it show up on Station View for a moment. I’m totally baffled as to how to solve this.

1 Like

If possible, it might be good to try to determine if it is a device or network problem. If it were me, I would be tempted to try taking it home and connecting it to my home network to see if it worked better there. If so, that tells us something …

If not, it begins to look like some sort of problem with the device itself.

Another thing you can try is to install Swarm somewhere on the same network, and use that to look at your device - see if it is recording complete and reasonable looking data.

1 Like

Hello planetarythinking, welcome to our community!

Thank you for the logs. From them, two things emerge. The first is this:

2022 117 08:23:36: WARNING: This IP address indicates you are exposing your Shake directly to the internet at large.
2022 117 08:23:36: WARNING: This is discouraged since this exposes the Shake directly to bad actors.
2022 117 08:23:36: WARNING: Because this is an IoT unit, our recommendation is to place it on a local network
2022 117 08:23:36: WARNING: Where a router exists between the Shake and the internet.

As written in the messages above, we do not advise an IoT unit such as our Shakes to be directly connected to the wider internet. This does not cause the connection problems that you are experiencing, but it would be an additional secure measure to not expose it in this way. I think you can contact your IT department and ask them to solve this condition.

Regarding the transmission errors, some data manages to pass every now and then, but after that, this messages appear continuously:

2022 117 09:06:39>>	DDSsendDP(): message send failed after 61 retries, closing connection.
2022 117 09:06:39>>	DDSsend(): Send error: 0
2022 117 09:06:39>>	sendDClientDP(): Error sending data ... 

To verify that the Shake is in working order, I advise you the same process that Philip suggestes, that is, try to connect the Shake to another network (home, another office, or similar) and see if the unit manages to reach our servers in a stable manner from there.

If it does, then I advise you to reach again to your IT department and ask them to crosscheck what they have done, because there is still something missing with data transmission permissions in their firewalls. If it does not, then please download again the logs and post them here, so that we can see what other solution we can pursue.

Thank you.

Thank you both very much PhilipPeak and Stormchaser. I’ve looped IT back in (I’m their favorite person at the moment) and we’ll try to operate the RS&Boom from a different location (fingers crossed the Shake is fully operational). I’ll be back in the forum if the problem persists and send new log-files.

Thanks again!


You’re very welcome, planetarythinking,

I will be waiting for updates, hopefully positive! :slight_smile: