Reset network config


A colleague and myself both modified repeatedly modified the network config in /etc/network/interfaces and /etc/dhcpcd.conf while moving our rs4d from place to place, sometimes using DHCP, sometimes fix IP, sometimes wifi, sometimes ethernet.

I’m now trying to setup at home, on my home wifi (which works fine with other seismometers), without success.

I’ve tried both How to configure Wifi and USB wifi dongles from command-line — Instructions on Setting Up Your Raspberry Shake and the webfrontend. At best, after following the shell procedure (including reboot, and ethernet disconnection), it does pop up on my local network for a minute when disabling/enabling wifi, and for a minute after each reboot. The logs are attached…

I suspect that we messed up too much with our config. Is there a way to reset all config files to default?



rsh.logs.tar.bz2 (189.1 KB)

Hello Fred,

thank you for the logs. I don’t know what exactly happened, but in some way both the LAN and the WiFi result turned OFF.

It is quite a strange case, the first time I’m seeing it. Also, yes, there are traces of the changes you made while you were using the Shake, and we are glad that it continued to perform well throughout all of them!

However, in this case, I would suggest that doing a wipe and re-burn of the microSD card is the best choice, to make you start with a fresh OS.

In case you need it, here’s the procedure for a from-scratch installation of our System:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

You can try to do it on the same microSD card, or if you have another MLC or SLC cards around, you can use those too.


Ok, thanks a lot. I was kind of hoping there would another way (I have one of these IP67 enclosure - hard to get through) but it sounds like the cleanest way.

I’ll let you know how it goes.




Done, that worked well…

1 Like

Thank you for the update fmassin, and happy to hear that your Shake is now working as it should!