RBOOM Server Connection Not Working


I have a RBoom connected up and running.
The system appears to work except “server connection - not connected”" comes up.
Initially at first I saw my station one but after rebooting it has never come back.
I reinstalled the image again but still “no server connection”
Any new suggestions for success ?

I am a new RBoom owner.
I just got system working but the server connection doesn"t appear to work.
I cannot get live data on the Shakenet.
I addeded port forwarding 55555 and 55556 tcp/udp on the the address of the Rboom but that doesn"t seem to solve the problem.
I am stuck at this point not sure if I did the port fowarding correctly or not or if I am missing something?

Hello Tom, and welcome to our community!

I’ve merged your topics as they are dedicated to the same issue you are experiencing with your RBOOM. Thank you for the troubleshooting you’ve already performed.

Could I please ask you to download the logs from the unit and post them (the instructions to do so can be found here: Please read before posting! ? They could provide more details on what is going on and I may be able to offer a solution to the current problem.

Thank you!

Greetings Stormchaser
I downloaded the logs as requested and tried to attached.
Didn" know if you meant for me to cut and paste the whole document here or just the attachment.
I cannot use local.RS but my found my IP
Let me know if you need something in addition.

RSH.R128D.2023-03-27T12_40_06.logs.tar (250.5 KB)


Iam also postinga picture from my router post forwarding.
I am not too knowledgible on port forwarding details.
Not sure what else I need to do for the port forwarding, and what is absolutely needed.

Greetings Stormchaser:

i tried changing my port forwarding again my router to include some of the items mentioned to be forwarded. But these changes did not help the “server not connected” problem. Any help would be greatly apprciated.

You don’t need any port mapping. That is for incoming connections.

The R-Shake only connect outwards. The R-Shake is not designed to be accessible from the Internet, so doing so could create security issues.

There do appear to be problems connecting outwards. My guess would be that your firewall is blocking most outgoing ports.

1 Like

Hello Tom,

Thank you for all the screenshots and the logs from the Shake.

It appears that you have your Stand-Alone mode turned ON, and this disables any server connection. This line shows it:

2023 086 01:59:27: STAND-ALONE Mode ON, not checking for a valid IP address

To turn it off, you can click on the Actions icon high on the left (hammer), then go to the Actions tab and click on the Turn off-line mode OFF button.

If the Shake still does not connect, then please reboot it, and after it has turned on again, please check that the Forward Data box is checked. You can find this box by clicking on the Settings icon high left (gear) and then on the Data tab.

If this doesn’t work either, please download the logs again and post them here, so that I can take a look at what they show after a fresh reboot.

Thank you!


The server connection still does not work.
I followed your instructions for the “off line mode” and rebooted.
I included a few screen shots, or initial screen and router.
Also included new log filesRSH.R128D.2023-03-27T21_20_01.logs.tar (360.5 KB)
Take a look at my router “port forwarding” do I need to remove those 55555 and 55556 settings?
Please advise

1 Like

While waiting for @stormchaser to come back on-line, I will give you my suggestion(s).
The logs show that your shake is connecting to DNS and an external NTP server ok:

         remote           refid      st t when poll reach   delay   offset  jitter
 SHM(0)          .GPS.            0 l    -   16    0    0.000    0.000   0.000
 SHM(1)          .PPS.            0 l    -   16    0    0.000    0.000   0.000   .STEP.          16 u    -   64    0    0.000    0.000   0.000
*gosanf.hojmark.     2 u   15   64   17   72.683   -0.368   2.394
 ns1.your-site.c .STEP.          16 u    -   64    0    0.000    0.000   0.000

However, the connections to the raspberry shake servers are not working:

=== Shake Data Server ===
 Name: raspberryshakedata.com
/usr/local/bin/myShake: line 396: NO: command not found
 Port 55555 : 
/usr/local/bin/myShake: line 396: NO: command not found
 Port 55556 : 

If you are comfortable with Linux command-line, you can ssh into the R-Shake and try to see if it is possible to connect to these:

$ nc -zvw5 55555

That will wither respond very quickly to tell you that it could connect, or after waiting for 5 seconds, it will time out with an error message.

If it fails to connect, I would remove the port forwarding for those ports and try again.
If that allows a connection to complete, reboot.


Thank you for the new logs and screenshots Tom.

I would agree with Philip, let’s try to remove all the port forwarding that you have made on your modem/router. Then please shut down both the Shake and your modem/router, start the modem/router again, wait for it to regain internet connection, turn on the Shake, wait for ~30 minutes from this point, and if the Shake still displays a “Not Connected” status, please download the new logs and send them to me again.

Thank you for your collaboration.


I removed the Rboom forwarding in my router/switch.
I shut down the RBoom and shut down the router.
I restarted the router and after a few minutes restarted the RBoom.
Unfortunately the server is still not working correctly, same as before.
included are the new set of logs as requested.
tomRSH.R128D.2023-03-29T00_43_15.logs.tar (1.1 MB)

Hello Tom,

Thank you for the further feedback and the new logs. It appears that the issue is strictly focused on some kind of connection issue between the Shake and the modem/router. This line shows it well now after a fresh restart:

2023 088 00:38:13>>	Connection attempt #1 (raspberryshakedata.com:55556) failed with error code: No route to host

If you haven’t already, I would advise to try to see if by connecting the Shake to a different LAN port on the modem/router, or changing the LAN cable, yields any positive effects. It may seem a very simple thing, but it has solved similar issues in the past.

If not, it also appears that the usual nameservers that we have introduced to facilitate connections are not present for some reason, so at this point I would prefer to reset the Shake OS to default and see what happens after a microSD re-burn. I will leave the burning instructions here for your convenience:

Once done, the Shake should be able to connect with no issues. If not, the new logs after the re-burn should tell us more.

Hi Stormchaser:
I followed your last post, i re-imaged the raspberry. I tried a new port and started everything router/modem/switch and all works perfect now.
Thanks so much for your help and persistence


That is great to hear Tom!

Happy to see your Shake online and transmitting live data! Station View: Raspberry Shake Network & EQ Activity Map

You’re more than welcome, it was no problem at all.