Raspberry Shake & SWARM in offline mode

Hi Everyone,

I’m using the Raspberry Shake in offline mode (no GPS) with stand-alone ON mode, for the purposes of an educational workshop. I can use the Shake with all its capabilities with the offline mode mode off, i.e. I can access the web front-end and see data streams (4 channels) on SWARM. However, when I take the Shake off the internet connection and connect directly to my laptop via the Ethernet cable, I don’t see any data streams on SWARM, even though I can still access the web front-end. Can you help me, please?

Best regards,

Savvas

1 Like

Hello Savvas, welcome to our community!

Thank you for explaining your issue. This is due to the fact that you are directly connecting the Shake to your PC without passing through a modem/router (How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake). The front-end remains accessible, but the rest of the services require a different configuration.

You will have to set your PC/laptop IP range in the same discoveryIP range that the Shake uses for direct connections, as shown here on our manual: Discovery IP — Instructions on Setting Up Your Raspberry Shake

Once this is done, your Shake should result visible, and you should be able to configure SWARM to read live data from it.

Hi,

Thanks for the suggestion! I’m a Windows user and have investigated this, and it seems that the shake has the IP address from the front end

> : 169.254.63.145

From what I understand, this is within the Discovery IP range. When I tried to manually specify an address for the ethernet port using Windows’ netsh (to 169.254.8.11, per the example in the docs), I couldn’t even connect to the front-end. However, even with this IP address for the ethernet port, I still can’t see SWARM live data streams. Do you have any suggestion for where I am perhaps going wrong?

Hello,

Yes, the Shake is predisposed to have its direct IP connection in the discovery range. You will have to set your local PC/laptop IP address in the same range so that the two devices will be able to communicate with each other.

Have you tried changing the PC IP manually, as shown in this guide I found online? https://www.onmsft.com/how-to/how-and-why-to-set-a-static-ip-address-in-windows-10

If you want, could you please post a screenshot of your local PC network adapter configuration, so that I may be able to see what is possibly causing the problem?

Thank you.

Hi,

I was able to get the shake to broadcast data to SWARM by manually configuring the SWARM source IP address, so problem solved! Thanks a lot for the help!

2 Likes

Hello SeismicSavi,

That’s great to hear! I hope that our Shake performance will satisfy you (and fascinate your students/coworkers) for the workshop you have planned!