Raspberry Shake & SWARM in offline mode

Hi Everyone,

I’m using the Raspberry Shake in offline mode (no GPS) with stand-alone ON mode, for the purposes of an educational workshop. I can use the Shake with all its capabilities with the offline mode mode off, i.e. I can access the web front-end and see data streams (4 channels) on SWARM. However, when I take the Shake off the internet connection and connect directly to my laptop via the Ethernet cable, I don’t see any data streams on SWARM, even though I can still access the web front-end. Can you help me, please?

Best regards,


1 Like

Hello Savvas, welcome to our community!

Thank you for explaining your issue. This is due to the fact that you are directly connecting the Shake to your PC without passing through a modem/router (How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake). The front-end remains accessible, but the rest of the services require a different configuration.

You will have to set your PC/laptop IP range in the same discoveryIP range that the Shake uses for direct connections, as shown here on our manual: Discovery IP — Instructions on Setting Up Your Raspberry Shake

Once this is done, your Shake should result visible, and you should be able to configure SWARM to read live data from it.


Thanks for the suggestion! I’m a Windows user and have investigated this, and it seems that the shake has the IP address from the front end

> :

From what I understand, this is within the Discovery IP range. When I tried to manually specify an address for the ethernet port using Windows’ netsh (to, per the example in the docs), I couldn’t even connect to the front-end. However, even with this IP address for the ethernet port, I still can’t see SWARM live data streams. Do you have any suggestion for where I am perhaps going wrong?


Yes, the Shake is predisposed to have its direct IP connection in the discovery range. You will have to set your local PC/laptop IP address in the same range so that the two devices will be able to communicate with each other.

Have you tried changing the PC IP manually, as shown in this guide I found online? https://www.onmsft.com/how-to/how-and-why-to-set-a-static-ip-address-in-windows-10

If you want, could you please post a screenshot of your local PC network adapter configuration, so that I may be able to see what is possibly causing the problem?

Thank you.


I was able to get the shake to broadcast data to SWARM by manually configuring the SWARM source IP address, so problem solved! Thanks a lot for the help!


Hello SeismicSavi,

That’s great to hear! I hope that our Shake performance will satisfy you (and fascinate your students/coworkers) for the workshop you have planned!

In case this is useful to others. I had the same issues using Windows.

I connected the shake through ethernet to my laptop. Used Bonjour Browser for Windows to find the IP address of the shake: 169.XXX.XX.XX ignoring the :9

then you can enter the IP in the Swarm config file at the line:

server=myShake;wws:169.XXX.XX.XX:16032:15000:1. Launched Swarm and the Shake was in Networks and streaming live data.


Hello pdcguy, and welcome to our community!

Just wanted to thank you for the additional insight and another method (Bonjour) that other users can utilize to find the Shake IP address.

Side note: Make sure that the time on the Raspberry Shake is set to the current time, otherwise the waveforms will not display in Swarm! If you type the command date after logging in via ssh, you can see the current date. The date can be updated using the command sudo date --set “yyyy-mm-ddThh:mm:ss”

It might be helpful if you could reset the date on https://rs.local/ in addition to using the command line.


The IP of each shake is easily found after plugging it in your laptop by doing rs.local and checking the numbers in the line: Ethernet Local IPv4. Then, copy that number in the config file and launch Swarm.


Yes, SWARM has a updated date/time requirement otherwise, as you have seen, it will not display data even if the connection details are correct.

It might be helpful if you could reset the date on https://rs.local/ in addition to using the command line.

This is a very interesting suggestion! I’ll put it on the software team’s radar so that they can see what work is required to add this feature in one of our future OS updates. Thank you!