Raspberry Shake/Boom

Greetings. I have an original Kickstarter Raspberry Shake, it’s working great. I also backed and received a Raspberry Boom. My problem is that the Raspberry Boom has taken over the rs.local network name. Since the network names were changed from raspberryshake.local to rs.local with system version 0.15 my boom claims the name even when booted after my shake. If I boot up the shake it is accessible as rs.local until I boot the boom. After my boom has booted up and I surf to rs.local I get the boom instead and the shake becomes rs-2.local. The boom is hard wired to my network and the shake is running on wireless. Is there any way to change the network name on the boom?

Thanks

Hi @Dlward50, welcome to the community. We’ve confirmed this problem exists and are looking into it. Thanks for your patience.

Thanks for the reply. Looking forward to a fix👍.

1 Like

Hi @Dlward50, we think we’ve narrowed down the name change issue to the OS using IPv6 services on the Pi. However I can’t reproduce the issue right now even though I’ve seen it happen before, so I don’t yet know whether this solution will solve it.

Can you try the following and report back? Edit /etc/sysctl.conf on both the Shake and the Boom and add the following lines to the end of the file:

net.ipv6.conf.all.disable_ipv6=1
net.ipv6.conf.default.disable_ipv6=1

Then shut both devices down completely. Start the one you’d like to become rs.local first, then start the other.

@Dlward50 to clarify, our sysadmin has confirmed this solution works but I was going to verify for support and manual update purposes. So you’re safe to try it without worry. I will be able to reproduce this problem on an isolated network this evening and confirm.

Thanks Ian, I’ll give it a shot when I get a few minutes to tinker. The Boom will be pretty easy as it’s sitting in my library on a shelf. The Shake, not so much. I have it mounted on the wall in my workshop to be as close as practical to the geophone which I separated from the RPi. The geophone is mounted in a separate location outside next to a retaining wall to isolate it as much as possible from all the vibrations we create in the house. I believe I disabled SSH access for security reasons. Thanks for the update. I’ll get back to you after I’ve tried it out.

Dan

Dan,

Another thing you can do is change the configuration file of the avahi-daemon for one of the two devices, to permanently pin it to a different DNS name.

So for the Boom you can do

sudo nano /etc/avahi/avahi-daemon.conf

and change the line

host-name=rs

to

host-name=boom

Once you reboot, the Boom will become boom.local so the Shake can have rs.local to itself.

I’ve added a section in the manual that explains why the DNS name change issue happens (it’s a bug related to conflicts between IPv4, IPv6, and RSTP protocols). It’s a short but hopefully informative read:

https://manual.raspberryshake.org/commonlyAskedQuestions.html#why-does-my-raspberry-shake-change-its-dns-name