Raspberry Shake&Boom - Wifi Problems

Dear all,

I have several problems with a raspberry shake&boom that my employer tasked me of fixing.

First of all, I need to ensure the general possibility of a Wifi connection, which I tried to realize by using the Wifi-Dongle EW-7811UTC which I installed using this tutorial How to install EW-7811 AC600 Series and EW-7822UAC adapters on Raspberry Pi : EDiMAX .
It is recognized by the device but not building a connection. iwconfig gives this:

The next issues would be connecting the device to an eduroam network using a certificate, which they already tried with another raspberry shakes that has included wifi and can connect to normal networks. However, the settings set in the terminal seem to be overwritten by the surface and thus it cannot use the certificate to connect.
The third issue would be connecting the shake to a laptop directly via USB without a network and just showing the recorded data on the screen for educational purposes.

Lets first focus on the first issue though. I hope you can help me.
Kind regards.

Hello ryu, and welcome to our community!

When you can, could you please SSH into the Shake (if needed, instructions are here: How to access your Raspberry Shake’s computer via ssh), print out the contents of the interfaces file with cat /etc/network/interfaces and post them here? Thank you.

When you say “settings set in the terminal are overwritten by the surface”, do you mean the configuration page rs.local/ with “surface”? If so, after setting up the certificate, what action on the surface appears to overwrite the configuration you have made via the command line?

For the third query, we do not recommend a USB connection between Shake and a local PC, but an Ethernet cable connection. Remember to set the PC IP address in the Shake discovery range, as shown on this page of our manual: Discovery IP Once done, you will be able to easily access all the data the instrument is recording, and see it on screen with software like SWARM, or similar.

1 Like

Hey Stormchaser,

Thank you for the warm welcome and the quick answer.

Certainly, this is the output:

Exactly. I mean the rs.local page with the settings set via the terminal. That was the description handed to me and unfortunately I can not work with the device they tried this on so I dont really have more information. I will recreate it as soon as the network works with the device I have been given and post the logs.

The third query… Yeah. Terribly sorry because I could have thought of that myself. They are organizing an adapter and I will work with it next week.

Best regards

1 Like

Update: After second it up newly for the third time I have made the Wifi work on my home network. I will update as soon as I have interacted with eduroam.

1 Like

I have finally arrived at the same problem my predecessors have. I have created an own certificate file from the python script installer from my employer and put it in place, but the shake will not connect. I have attached the iwconfig and the contents of wpa-supplicant…
I dont know how they tried to connect via the web interface as it will not work for eduroam imo…
Which log files do you need?

Kind regards