Raspberry shake 1 D stopped connecting

Hello, I changed computers and my shake is now powering up, with a flickering green light but it won’t log any data and it won’t get connected to the software. I have the ethernet plugged into my windows 10 computer and the USB power cable. When I try and download log files nothing comes up so I can’t send them.
I am R4277.
it says RS4D
3 model B
system version 0.19
Ethernet local IPv4
Ethernet Mac : b8.27.eb.cd.42.77
data producer on
data consumer on
off line mode off
data forwarding on
sever connection not connected
lat and long
and system time etc

Hello grazhobart, welcome back to our community!

Without the logs, unfortunately, I cannot be precise in my advice, but here’s what you can try.

  1. Could you please reboot the Shake again and then try (even if you have already) the following procedure to see if it solves the connectivity issue?

Please access your rs.local/ page, go to Settings (the gear icon high on the left), and then the Data tab. Make sure that the Forward Data box is checked, and then click Save and Restart.

The station should now be able to connect again.

If it does, then this error is caused by a known bug that we are examining and that will (hopefully) be solved in the next Shake OS v0.20 release.

  1. Instead of powering the Shake via USB, please try to turn it on using a classic power supply, if possible. This part should be able to provide between 5.0 and 5.2V and at least 2.5A for the Shake to operate normally.

  2. If nothing of the above works, then I would recommend re-burning your microSD card, so that anything that may be causing the log problem and/or the connection one may be solved. I will post the burning instructions here for your convenience:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

RSH.R4277.2019-03-15T20_44_42.logs.tar (114 KB)
here are the log files after I found a POWER ADAPTOR AND REBOOTED TWICE


thank you for posting the logs from the Shake. Everything seems fine during the booting process until the Shake has to find a network. Then this error appears:

2019 074 20:31:56: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available
2019 074 20:31:56: No internet connection found
2019 074 20:32:08: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available

This is the very likely cause of the connectivity issue you are experiencing.

Could you please shut down the Shake and then your modem/router? Check if the LAN cable connecting the two is in good status, and if you have another CAT6 cable or superior version around, feel free to try that one too.

Now restart your modem/router, and wait until it finds a stable internet connection. Once this has been achieved, only then turn on again your Shake, and wait for it to find a network. If the status remains still “Not Connected” around 30 minutes after turning it on, then please download the logs again and send them to me, so that I can see if there is something else that we can try.

Thank you.

Ok, what I did was ditch the old card, re burn a new copy on a brand new card, got the blue and green lights ok, then plugged it into the ethernet on my computer- Windows ten. No go.
Then I read that it must be into an ethernet port on modem etc- I did just that and it didn’t work and also disabled my WIFI for 2 hours.
I am guessing there is a conflict between the shake and the modem/router.
I have an ethernet switch pory/POE on order and a mPOE to 5v converter as my ultimate aim is to power the shake and an all sky camera raspberry pi via POE away from the house. Any thoughts?

Hello grazhobart,

Yes, this seems to be a case where there is a clear conflict between the Shake and the current modem/router. We had some of them in the past. The majority were solved when the user called the internet provider that had supplied the modem/router, while a couple of other users had to buy an entirely different model for the Shake to connect.

Unfortunately, with the myriad of brands/models that are available on the market, we cannot provide a very detailed support, and limit ourselves to general indications.

However, if you want to directly connect your Shake to your PC, you can follow these instructions, remembering to change the PC IP range so that it should see the Shake:


We have users that have their Shakes on POE, and they seem to work fine, so I don’t think you will have issues with that. Just ensure that the power supply is stable and is capable of providing constant supply.

The installation of both a Shake and an allsky camera sounds definitely amazing! When you manage it, please feel free to share your pictures of it!

here is my log- it will probably say the same as its back in my computer ?RSH.R4277.2021-10-21T21_11_00.logs.tar (4.3 MB)

my mate has suggested using an ethernet switch from the modem then a POE adaptor to 5v for the shake?

Hello all, I managed to ping it via command prompt line when it was attached to my computer via ethernet, I changed my SSH password and logged on, but don’t know what to do next ?
(as a contingency I also ordered a new card although my burnt copy seems to be ok?)
Also when are you doing R.Pi t shirts ? would like to wear my affiliation !!

Hello grazhobart,

Thank you for the new logs and the screenshots. I can see that you successfully managed to connect on a local network with your computer, great work!

You can see if the Shake is now recording data by clicking on the current Helicorder display (the first icon in the bottom bar) and then clicking on the appropriate day/time link in the page that appears after that.

From what I can see, there should be any problem in this. Naturally, since you are connected directly to your computer, there is no outgoing general internet connection. For that, you will have to disconnect the Shake from the PC, and try again with your modem/router, to see that:

  1. the Shake is seen in your local network and is correctly assigned an IP address, and
  2. that you can access rs.local/ from a PC connected to the same local network.

After that, all that remains is to manage other issues if the Shake still displays a “Not Connected” status. But we can get there one step at the time.

Ok -got it connected with server, and its recording on the heligraph, but not yet showing on station view. How long does that normally take?

NB used a ethernet POE switch from the router and then a 5V POE and ethernet splitter, so when the time comes I can power my all sky/meteor pi camera from the same switch

still not showing, here are log files RSH.R4277.2022-02-02T07_29_07.logs.tar (2.5 MB)

tried rebooting, says connected but nil so far RSH.R4277.2022-02-02T09_07_01.logs.tar (2.5 MB)

Hello grazhobart,

Thank you for the updated logs.

Everything seems fine, but it can take up to 24h before the Shake will again be visible on our services. It seems that we now have a connection with our data center, and the instrument seems to be transmitting.

Let’s wait out this period, and if it doesn’t appear after that, we will look at other potential solutions.

Thank you for your patience in this.

Great! That is good news! :sunglasses:


And, in fact, here it is again on our StationView: RS StationView

And DataView: RS DataView BETA

fantastic! now to resurrect my older shake and see if I can make that work!


Hello Stormchaser, I powered up my older version shake with a new power source and a new burn of the software, it booted (I saw the lights blinking etc) and it is attached to my router, but when I do Rs.local/ I just get my existing shake number come up. What do I do if I want to run both from the same router?
They will eventually be in different spots but currently are very close when I iron out all the bugs.

1 Like

Hello grazhobart,

Glad to hear that! It’s always great when something starts working again!

You have two possible options regarding having multiple shakes connected to the same local network.

The first is to access them via their different IP addresses, just write those into the address bar of your browser instead of rs.local/ and you will be set.

Otherwise, the first Shake connected to the network will always be rs.local/, then the second will be rs-2.local/, the third rs-3.local/ and so on.

You can choose what method is the best/easiest for you.