R363F (not) on line

A couple weeks ago it seems my RS1D stopped talking to the community server. I did not notice since I use the local connection here. It started to dawn on me that something was wrong when EQinfo kept giving a blank trace for my station. And then I got an email from your “robot”.

I have rebooted and power cycled the RPI and rebooted my router. What I see on the log files is that the RS1D RPI cannot reach anything on the internet. So it’s not able to connect to the server, I guess. From the RS1D, I can ping nodes on my LAN, but not addresses on the internet.

I have attached a log file.

RSH.R363F.2023-05-02T20_48_33.logs.tar (3.1 MB)

Looking at my router I don’t see an indication it is blocking.

Note that I have an RBOOM on the same system and it is working fine. I also tried this on RS1D and it looks ok.

cat /etc/resolv.conf

Generated by resolvconf

domain fios-router.home

anything else to look at?

I tried this:
sudo systemd-resolve --flush-caches
Failed to flush caches: Unit dbus-org.freedesktop.resolve1.service not found.

That command works on RBOOM

1 Like

Hello kpjamro,

Thank you for the logs and the troubleshooting you have already done. It appears that, as you showed, the Shake cannot find a network:

2023 122 16:39:27: Network detection failed, unable to curl or ping common sites
2023 122 16:39:27: No internet connection found
2023 122 16:39:27: Network detection failed, unable to curl or ping common sites

It also appears as the communication ports (55555 & 55556) are not open on your modem/router, but, as you have already checked, the issue has to be somewhere else:

2023 117 21:49:24>>	Connection request (raspberryshakedata.com:55555) failed with error code: Connection refused

Could you please SSH into the Shake again, execute cat /etc/dhcpcd.conf, and post the output here? Thank you.

here it is:

interface eth0
static ip_address=
static routers=
static domain_name_servers=

A sample configuration for dhcpcd.

See dhcpcd.conf(5) for details.

Allow users of this group to interact with dhcpcd via the control socket.

#controlgroup wheel

Inform the DHCP server of our hostname for DDNS.

Use the hardware address of the interface for the Client ID.



Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.


Persist interface configuration when dhcpcd exits.


Rapid commit support.

Safe to enable by default because it requires the equivalent option set

on the server to actually work.

option rapid_commit

A list of options to request from the DHCP server.

option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes

Most distributions have NTP support.

option ntp_servers

Respect the network MTU.

Some interface drivers reset when changing the MTU so disabled by default.

#option interface_mtu

A ServerID is required by RFC2131.

require dhcp_server_identifier

Generate Stable Private IPv6 Addresses instead of hardware based ones

slaac private

A hook script is provided to lookup the hostname if not set by the DHCP

server, but it should not be run by default.

#nohook loo
denyinterfaces wlan0
=== the end ====

OK - I see what’s missing.
I just fixed it and it seems to be working :slight_smile:

FWIW - I think these entries were created by the menu/gui - not me editing the file.

1 Like

Hello kpjamro,

Thank you for the file content! Can you please try the following?

Please open again the dhcpcd.conf file with

sudo nano /etc/dhcpcd.conf

Delete all the lines that start with static, if present (as is this case), thus leaving only interface eth0. If the line interface eth0 is not present, then add it (not this case, but a useful general reminder). Do not modify anything else.

Then do:

sudo service dhcpcd restart

to make sure those changes took hold and then check the output file with

nano /etc/resolv.conf

This should renew the configuration, and possibly, solve your connectivity issue. If the Shake still doesn’t connect after this last command, try rebooting it again.

If it still doesn’t connect, please download again the logs, and post them here alongside the contents of the files dhcpcd.conf and resolv.conf. Thank you.