Problem with ethernet connection

In the last few days I have had problems with the RS, it started when they changed the internet modem that was failing for a new one, but they did not notify me and I could not turn off the RS, they simply connected the ethernet cable to the new modem and I could no longer access to the RS configuration to make the corresponding network changes.

After trying several things to be able to access the rs.local website, I decided to replace the Ethernet cable with another one and that worked, it connected to the wifi and I was able to access the website.

Realizing the fault was in the cable, I took apart the old cable and realized the problem was that it had become disconnected from the pins. I fixed it and reconnected it to the modem, it worked but when I turned it off and on again it turned out that now the ehtenert LED lights are no longer on, nor are the modem LED lights, but I can still access the website and everything seems fine .

What’s happening? Was Ethernet damaged by the abrupt network change?

I attach my .Log files
Thank you for your answers.

RSH.RB581.2023-11-02T03_13_35.logs.tar (4.1 MB)


Hello ElSismologo,

Thank you very much for the logs, the explanation about the steps you have gone through, and the pictures you’ve attached.

For some reason, it appears that the LAN connection is OFF

2023 306 01:06:17: Ethernet is OFF and WiFi is ON

and this is the reason why the lights are not turning up, as your Shake appears to be connected only via WiFi, as you have stated.

If you haven’t already, have you checked that the new cable is in working conditions and that the wires are still connected to the pins?

Also, could you please SSH into the Shake (instructions here: How to access your Raspberry Shake’s computer via ssh), execute the following command cat /etc/network/interfaces, and copy/paste the result here?

Thank you.

1 Like

I have this

Thank you ElSismologo,

From this, everything looks fine, and the configuration is as it should be. To check if everything hardware-side is all right, could you please unscrew the clear plastic top, gently disconnect the LAN cable inside, connect another LAN cable that you know is in working status to the Pi Ethernet port, and see if the green and orange LEDs light up?

Thank you.

1 Like

I solved it, what happened was that the ethernet cables had come loose from the pins, I had to cut the plug to reconnect them.

Now I think everything works fine, here are the Log files.

RSH.RB581.2023-11-03T16_46_15.logs.tar (4.1 MB)


Hello ElSismologo,

Yes, from the logs (and your pictures) all appears fine now. All the lights are on, the Shake boots as it should, finds an internet connection fast, and then starts uploading data to our servers.

Good eye in noticing that the cables had come loose from the pins so you could reconnect them properly.

If you require anything else, I remain available as usual.

1 Like