Please assist with Server Connection: Not Connected issue

With limited internet connectivity, I had been running my RS3D in standalone mode for c. 45 days. With a connectivity improvement, I’ve being trying to connect for the last two days with no joy. Please find attached my log files.


MRT, P. Geol

RSH.R6843.2022-01-20T19_31_18.logs.tar (3.8 MB)

Hello MRT1953,

Thank you for providing the logs from your Shake. It seems that the internet connectivity is still a problem, because the unit cannot find a network to connect to, probably for the reasons you have listed. These lines show the issue:

2022 018 17:24:47: Network detection failed, unable to curl or ping common sites
2022 018 17:24:47: No internet connection found
2022 018 17:24:47: Network detection failed, unable to curl or ping common sites

Could you please shut down the Shake and then your modem/router? Check if the LAN cable connecting the two is in good status, and if you have another CAT6 cable or superior version around, feel free to try that one too.

Now restart your modem/router, and wait until it finds a stable internet connection. Once this has been achieved, only then turn on again your Shake, and wait for it to find a network. If the status remains still “Not Connected” around 30 minutes after turning it on, then please download the logs again and send them to me, so that I can see if there is something else that we can try.

Thank you.

Thanks, Stormchaser, for your support, as always. The problematic connectivity was using a Cat5 cable via a ZTE MF279T Rocket Hub which Fing tells me offers an average 35 Mbps down & 5 Mbps up with a 96 sec latency. I relocated the RS3D to connect it via a 50’ Cat6 cable to the family’s cable modem, which Fing tells me offers an average 300 Mbps down & 16 Mbps up with a 33 sec latency. Ran it for a few days but still Not Connected, and the UTC clock is now very out of sync. Did a dawn reboot today, but still no joy. Please find attached my logs. RSH.R6843.2022-01-30T23_16_24.logs.tar (3.9 MB)

Hello MRT1953,

You’re welcome, no problem at all!

Yes, I can see from the logs that the issues seem to be the same, and in some way they have doubled down because now no NTP time servers can even be found from the instrument. This is why the UTC clock is very askew.

In some cases, if the time difference between the NTP server and the clock is too large, there could be the need for a manual NTP reset before connecting the Shake again. This manual page describes the procedure: Offline and stand-alone applications (like classroom demos) — Instructions on Setting Up Your Raspberry Shake

Otherwise, you could re-burn the microSD card and start again with a fresh system, to see if this solves the issues you are experiencing. I will post the burning instructions here for your convenience:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

Thanks for these detailed instructions, Stormchaser, which are way above my (retired) pay grade, and a full four decades since my past coding efforts! I’ll now have to wait until a grandkid comes back from uni to assist me with these recommended steps. In the meantime, I’ll buy a microSD from the RS site, so I’ll have a spare in case of foul-ups.

1 Like

That can also be a solution, yes!

We are working to streamline all these more technical processes as much as we can, so that our user can relax and enjoy the product, but some of them still require a bit of tech operations to get things going.

If you need anything else, I remain always available here.