Pi Zero W WiFi Died; Best Fix Option?

I have a self assembled Shake with Pi Zero W (AM.R1D51, from several years ago). It was working; now no WiFi signal. Fing still has it’s name and it and router show no signal. Unable to connect with Ethernet over USB. So no remote access.

As first step, where are the log files? If available, plan is to read the files (with a Win 10 Linux file program) on Win 10. If that works, maybe I can solve the problem or I can then email the log files to you.

If the Pi Zero W WiFi is “terminal”, advice please on next option: 1. Buy new Pi Zero W. 2. If Shake case for Pi 3 B or Pi 4 is available, buy case. (For Pi 3 B I need USB WiFi, right?). 3. Other options you suggest. For option 1, are setup instructions and image still available? It’s been decades since I worked on a Unix based system, so the more help information, the better.

Hello Morphix, welcome to the community!

From your description it seems that the WiFi module of the Pi Zero doesn’t work anymore, so if you want to use the same Pi model I can advise you to buy a new one, reassemble the Shake, re-burn the microSD with the latest ShakeOS and you should be operative again.

Be mindful that installing a new Pi board will change the Shake station code, as per our naming convention: Raspberry Shake Naming Convention — Instructions on Setting Up Your Raspberry Shake

However, before this, let’s try to see the logs from the Shake to get a better grasp of the issue. They are contained in the following folder:


Inside the microSD card. You can extract all the logs from there, zip them, and attach the zipped file to your answer.

Maybe they will give us more insight on what’s happening.

Thanks very much for your helpful reply.

Log files are attached. Also, screen display on boot up had line: “Failed to start: Raise Network Interfaces”.

I also reconfirmed correct WiFi SSID and password.

FYI for others: I was unable to get a Linux file read program working on Win 10 - but from Raspbian I copied the log files to a new directory in /boot making them available on Win 10.


Hello Morphix,

It’s good that you were able to access and read through the logs. Unfortunately, I think they did not get attached properly since I cannot see them.

Could you please re-attach them in a new message? You can also use Dropbox, Mediafire, or similar services, if the attach system of the community doesn’t work for you. Thank you.

logs.zip (284.6 KB)

Sorry about that. I got lost looking for “attach”, then got distracted, later noticed that I still needed to hit “Reply”, so I did…of course “upload” is the same.


Hello Jac,

Thank you for the logs. From them, I can confirm your suspicions. These lines:

2021 174 23:20:21: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available
2021 174 23:20:21: No internet connection found
2021 174 23:20:35: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available

2021 174 23:22:50: Unable to find an interface named either eth[0-9] or wlan[0-9] with a valid IP address
2021 174 23:22:50: Ethernet is OFF and WiFi is OFF

show that there are critical problems with the connectivity module of your Pi Zero, and that it is impossible for it to connect to a network.

At this point, to bar the possibility that some file in the OS has been corrupted, the next step would be burning again the Shake OS on the (or a new) microSD card.

Here are the details on which microSD cards to use (MLC is fine): https://manual.raspberryshake.org/burnSD.html#microsd-card-facts

While here is the process to prepare the microSD and burn the new Shake OS image on it:

  1. Please take the microSD card you have and format it before burning the new Shake OS image.
  2. Make sure, when you format it, that the shown capacity is the maximum (i.e. if the SD card is 16GB, then the capacity should be near or equal to that value). This is to check that no partitions have been involuntarily and erroneously created.
  3. Take care to format the SD card in a FAT32 File System (or exFAT if the SD card is 64GB or larger)
  4. Please download the new Shake OS image from here: https://gitlab.com/raspberryShake-public/raspShake-SD-img/raw/master/raspishake-release.zip
  5. And follow the microSD burning instructions from here: https://gitlab.com/raspberryShake-public/raspshake-sd-img/-/blob/master/raspishake-microSD-card-software-Instructions.txt

If this does work, then the Shake will boot up again fine and you should be able to see the details in the rs.local page. If it doesn’t, and the same issue appears, then we can be sure that the Pi board is the problem, and that it will need to be replaced.


The start was so promising…It “Raised network interfaces” and there were no other errors! But - the keyboard was not recognized on the USB port. Put the SD card back in the PC - no Boot partition. How do I change wpa_supplicant to setup WiFi and change my password? Is there a different image install package for PI Zero W? (The old image still recognized the keyboard).

Image downloaded from https://gitlab.com/raspberryShake-public/raspShake-SD-img/raw/master/raspishake-release.zip



Update: Found boot partition, will copy wpa supplicant.conf to new SD card. With luck, rs.local will work (have had problems in the past). I provide update.



The last time I worked on this was late 2017 - cobwebs all over the place.

ifconfig only shows the docker and loopback interfaces and there is no dhcp address assigned to the Rshake. Off to Amazon… I at least will have an upgraded Raspberry Shake image.

Thanks very much for your help.

Hello Jac,

Thank you for the step-by-step details that you have provided, I’m sure that they will be useful to other customers in the same situation.

To answer your question, no, the Shake OS image is the same for every Pi board, and it adapts itself to what is installed together with the Shake board. Some users have, however, reported back that the previous version (v0.15) seem to work better with some Pi Zero boards (unfortunately, this still seems to be a random occurrence, and not a defined one).

If you still have problems with your new board, you can try the older version as they did, to see if it will work. It can be downloaded from here: old · master · raspberryShake-public / raspShake-SD-img · GitLab and you can follow the same provided instructions to install it.

AM.R1D51 has been resurrected.

I tried V16 with the original Pi Zero W and it too did not work (no wlan0). I then replaced the Pi with a new Zero W and V16. Still did not work (see attached log file). I then tried V15 and it worked. Went back to the original Pi with V15 and it worked! AM.R1D51 is now back on its cement pad, shaking away.

I am very grateful for your assistance. Thank you!

wpa.log (1.1 KB)

Hello Jac,

That’s fantastic to hear! Yes, we decided to put the v15 just for the reasons that you have described. For some of the Pi Zero models the V16 works completely fine, but for others, it seems that the V15 is the way to go.

Glad to have your Shake online again!