PI not connecting with my board at boot time

My system quit working about 6 months ago, and I’m just now getting around to troubleshooting it. What I thought was a protected waterproof location wasn’t as protected as I thought, and I found some water marks on the board. I tried cleaning it off with contact cleaner, but I haven’t been able to get it to work. I did manage to get the D3 light to come on, and have a 5.1v at the board.

I had hoped to donate this system to a local school for a real time “our world” kiosk in their lobby, but I’m worried now about the board.

Any suggestions on how to proceed?

RSH.R0FA6.2022-04-09T21_59_23.logs.tar (3.7 MB)

1 Like

Did you try removing the RS board and cleaning the GPIO pins, then re-assembling?

Thanks for the suggestion. I tried cleaning them, but it didn’t fix the problem.

Hello Munnecke,

Thank you for the pictures, and the logs from the Shake. It seems that yes, the system starts, but then something prevents it from proceeding forward. These strange characters in the boot log itself are a good proof of the problem:

set-dns: †Àüp0‹J“}!Z
ŠÜ÷é¢Ë¤Sñë0–ðñ„w8´ëz4Õ:àECJß9ƒ×bTøÁ@6²Ä­I	Wþ ›t!Äàp:ê/

I would advise to try to re-burn the microSD card, and see if the Shake manages to successfully start and connect again.

I will post the burning instructions here for your convenience:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

It seems, to me, that there is some kind of corruption on the microSD card going on, so this should solve the problem. If it doesn’t, please try again with a different microSD card, or with a different Pi board, to check out all the possible components on the Shake.

thanks for the advice. I tried to format my old sd card, and it failed to format with some message about blocks. I then tried a new install on a new card, and got the same stuck in booting mode. I then tried a new install on a new Pi 4 computer, and got the same result…

RSH…2022-04-11T18_38_35.logs.tar (27 KB)

Hello Munnecke,

Thank you for all the further tests, the new logs, and also the Pi board change.

Unfortunately, considering your test results, I fear that the Shake board doesn’t seem to respond anymore to the Shake OS, which starts fine, even finds a stable internet and timing servers connection, but cannot communicate with the blue board on top of the Pi.

Due to your description, I think that the water has damaged some components on it, making the board unusable. My only advice, at this point, would be to buy a new DIY kit (since you already have a Pi board and power supply) for the Boom, and then re-build everything with the new pieces.

thanks for your help in troubleshooting. My suspicion is that it was just the board, and the sensors are in tact.


No problem at all. I agree, it is likely that the fault is in the board since that is where you found the water marks.