NTP stop getting connection, raspberry shake 3 1D

Hello , since I am looking around the forum for a while, and saw some related topics, but I still can’t find a way to solve the problem … The raspberryshake 1D was operational for a few months without an internet connection, then I finally managed to relocate and connect it to the internet . I notice that the system time is not up to date and I started looking for the problem and the solution,
I found:

  1. that the NTP is not connecting to any of the services.
  2. add new servers, and nothing.
  3. I see no adjustment in the ntpq -p
  4. The search results are confirmed by the log files.
  5. I have been able to ping the raspberryshakedata.com from the shake terminal
  6. And of course, I cannot see the station in the Station View because the data don’t have the timestan correctly

Could you help me adjust the time. ??

Ricardo from Venezuela.
Uploading: RSH.RCC5F.2020-07-24T07_05_30.logs.tar…

Can other devices on the same network access NTP? If not, it may be your router. My 'Shake seem to have no issues with internal or external servers:

C:\Windows\System32>ntpq -pn raspi-14
remote refid st t when poll reach delay offset jitter

* .GPS. 1 u 2 32 377 1.479 -0.005 0.273
+ .kPPS. 1 u - 32 377 2.151 +0.080 0.680
+ .kPPS. 1 u 16 32 377 2.153 +0.177 0.498
uk.pool.ntp.org .POOL. 16 p - 64 0 0.000 +0.000 0.001
- 2 u 57 64 377 19.060 +3.108 1.835
- 3 u 35 64 377 23.336 +1.530 1.182
- 2 u 44 64 377 19.299 +2.699 1.055
- 3 u 4 64 377 23.796 +1.701 2.229
- 2 u 7 64 377 38.074 +2.607 3.210
- .GPS. 1 u 20 64 377 34.692 +2.816 1.254

I’m using NTP 4.2.8p11 which is out of date, I know, but that shouldn’t affect connectivity.

C:\Windows\System32>ntpq -crv raspi-14
associd=0 status=0618 leap_none, sync_ntp, 1 event, no_sys_peer,
version=“ntpd 4.2.8p11@1.3728-o Wed Feb 28 09:21:50 UTC 2018 (1)”,
processor=“armv7l”, system=“Linux/4.4.26-v7+”, leap=00, stratum=2,
precision=-20, rootdelay=1.479, rootdisp=3.944, refid=,
reftime=e2c9134a.682c5617 Mon, Jul 27 2020 9:48:10.406,
clock=e2c91403.b6707f11 Mon, Jul 27 2020 9:51:15.712, peer=19584, tc=5,
mintc=3, offset=-0.005358, frequency=-1.522, sys_jitter=0.256177,
clk_jitter=0.274, clk_wander=0.127

hi ricardo,

there is a bug setting the hardware clock when it is very far off from actual time. this has been fixed and will be released as part of the next update. in the meantime, you can get around this problem by:

  1. log in to the shake using an ssh connection
  2. set the date with the following command, picking a date and time relatively close to actual time (n.b., this must be UTC time, not local time):
    > sudo date --set "2020-7-27 12:35:52"
  3. and then reboot your unit

when the date and time is close to accurate, the ntpdate service executed at boot-up will succeed, your unit will connect to an NTP server, and will continually stay sync’ed to keep proper time.

hope this helps, let me know if you have any other questions,


Hello, Ivor,

Thank you very much, I just did your step suggestion and it correct the date and time.

Stil do not have connection with the NTP server, but a less the station it is now live on eq view and swam. I will try to recheck the port at the router.

Thank you again for your attention.



hi ricardo,

glad it helped. can you upload your log files again please? there’s something i’d like to check if you don’t mind.

thanks in advance,


RSH.RCC5F.2020-07-28T23_11_30.logs.tar (4.3 MB)