No WiFi connection

I’ve recently dusted off a (previously working, Pi 3 B+ based) 1D unit, did a clean install of the v18 image, went thru the steps to edit wpa_supplicant.conf with my network credentials (as well as verified the network interfaces file) … but try as I might (spending a couple hours perusing the Shake and Pi forums), I simply cannot get to the Shake Dashboard over my local network.

I’ve tried a couple of Pi 3 B+'s … they work fine wirelessly on my network (5G) when just running Buster. Further (for the Shake) ifconfig indicates that wlan0 is being assigned an IP address (which I also see on my Eero router table), yet I can’t ping or ssh to the unit or connect via rs.local or its IP address.

Seems like I must be overlooking something simple … would appreciate any suggestions.


hi larry,

there are a couple of things you can try:

first, connect the unit to your router using an ethernet cable. connect to the front-end interface by specifying either rs.local or the actual IP address assigned to the unit. (the assigned IP can be found using Fing, or some other like program.)

second, use the FE interface to connect to a WiFi network; it is not necessary to configure a WiFi connection from the command line. you can find this under the section SETTINGS::NETWORK.

on the other hand, it is strange that ifconfig returns an assigned IP address for the wlan0 interface while ping is failing. when this is the case, from the Pi, can you ping out to some other computer?

hope this helps, let us know how it goes,


Hi Richard -

Thanks for the quick response and suggestions. Direct wired connection to the router did quickly bring up the FE interface and allow me to proceed to the WiFi set up process. The unexpected thing though is that it’s not liking my credentials. Not exactly sure why (I’ve got several RPi’s on the same network … Octopriint servers, etc.) Could it perhaps be that my SSID has an underscore in it … i.e. mynetwork_2 ? I can’t surmise any other possibility at the moment,

I should add that when connected to the router I get the following response to an ifconfig command … ‘wlan0: error fetching interface information: Device not found’. (Perhaps this is normal behavior however)?

Thanks again,

To your other question, yes, I am able to do outbound pings fine when I am connected to the network wirelessly and can observe an assigned IP in my router DHCP table … the unit will just not respond to any inbound attempts.

can you send your log files so i can have a look? they can be downloaded from the main page of the FE interface.


Sure … here you go. Fyi, I’m just using the Pi 3 B+'s internal WiFi … no dongle.


RSH.RB44E.2020-05-26T13 42 05.logs.tar (129.5 KB)


the log file myshake.out says that the wlan0 is active and has been assigned an IP address of

can you confirm that with Fing or some other like program? and / or put that IP address into a web browser of a computer connected to the same router, wired or wireless, which will bring up the FE interface.

from the log files you sent, everything appears to be working okay.


Hi Richard -

Well, the short (but quite puzzling) story is that at the moment everything appears to be operating just fine now.

When I sent the log files earlier I confirmed that I still wasn’t able to communicate with the Shake (via IP, ping, ssh, etc.) even though it had the IP address you indicate and was itself able to ping. So I just left it on and went about doing some other things for a few hours. When I returned to the setup, without changing anything (that I’m aware of), all was now normal with the unit … I could access the FE interface via IP, ssh into the unit, etc. Very strange indeed … I literally changed nothing.

That however got me to recalling a somewhat similar situation I encountered on my home network a couple years back when I had a similar struggle bringing a webcam online. Same deal, hours of trying every sort of configuration with no luck. Leaving that alone out of frustration, then coming back the next day … all was fine.

I run a Eero mesh network, so I called their technical support folks and went over the situation with them … wondering why a unit that was unable to join a network would mysteriously be able to do so if just left alone for a few hours. We reached no satisfactory technical explanation of why something like that would happen. I always feel a bit uncomfortable not knowing ‘why’, but just left it as an unsolved network mystery. (The camera has not been offline since for a couple years now).

Anyway, at the moment (after about 6 hours running so far), it looks like there’s nothing left to resolve, so this one might tentatively be ‘case closed’.


However, by the way, I still can’t use the FE interface to join the network … I keep getting the ‘Credentials were not valid’ response. I’ve just had to manually add them to the wpa_supplicant.conf file.