Newly deployed R5D1F is not showing up in StationView or Swarm

#1

Our newly deployed R5D1F is not showing up in StationView or Swarm. I am uploading the log file.

#2

Hi @shakes_msu—a couple of things:

First: just so you know, we got your logs but removed them from the post because an error message within them contained your email address. We take privacy very seriously and as such our lead developer (@ivor) will make sure this does not happen in the next software update. The reason this happened was in part due to the strange nature of the error, so…

Second: this is a strange case. For some reason the software is running into a problem where the root user doesn’t have permission to write to at least one critical file (/opt/settings/sys/ip.txt). We have seen this only a few times before and are perplexed as to why it might be. Has anyone modified permissions for any of the files in the OS?

If the answer is no, our working theory is that your SD card is corrupted and you should replace it with a high-endurance card like one of the following:

If you have any questions about any of this, please let us know. Thanks.
Ian

#3

Hi Ian,

Thank you for looking into this. I need to double check with the IT person who helped me set up the device. But on the other hand, I do see the device is collecting and accumulating data if I connect to it through ssh.

Min

#4

Hi Min, that behavior is consistent with what we expect to happen in this case. Locally, data will be recorded normally. The permissions issue means that R5D1F metadata isn’t compiled properly, so it can’t send any metadata to the server, so when the Shake tries to send seismic data to the server, there is no R5D1F station to attach that data to, because there is no R5D1F metadata on the server.

Can you send the output of

ls -l /opt/settings/sys/

I’m wondering if we can manually change the permissions back somehow, and whether it would stick if we did.