New user, static not connecting after setting static ip

Hi, really pleased to be joining the network

All was working when booted up first time and entered all the settings, connected ok,
On my network for the weather station everything is set up to static ip’s.
So I entered 192.168.2 232 as my chosen ip, save rebooted, it didn’t change my ip, still on the on allocated on set up Now it does not connect,

rsh-fe-hst.log shows
(‘network: ‘, {u’dhcp’: False, u’adapter’: u’eth0’, u’dns’: u’’, u’ip’: u’’})
socket.error: [Errno 32] Broken pipe

From post boot log
2021 078 12:42:11: Unable to resolve hostname ‘’, most likely no DNS server available

DNS is correct, Its not seeing the gateway, how does one check the gateway setting,

I have no knowledge of raspberry OS etc, I have the logs but can’t see how to attach to post.
Any help much appreciated

Update - Sorted I think, found the set up for static in the docs, used putty and went to
sudo nano /etc/dhcpcd.conf

interface eth0
static ip_address=
static routers=
static domain_name_servers=

I changed static from above post to 203, edited and saved to

interface eth0
static ip_address=
static routers=
static domain_name_servers=

Unit shows connected now, updating to static appears not to work from the web interface

Not showing on map yet but
One happy chappie here now back online

I Have a construction site nearby, Helicorder looks bad

Hello smokie, welcome to the community, and glad to have you back with your Shake!

Could you please post the logs from the unit, so that I can take a deeper look into your situation?

In case you don’t know or don’t remember how to do it, they are downloadable from the Raspberry Shake’s web configuration page, accessible entering the rs.local (or the Shake IP) address in your browser, then by clicking on the “Download Logs” button.

Thank you.

Thank you.

Thank you for your reply

The phone app says I’m offline, but unit says connected, are you receiving data


RSH.RD232.2021-03-19T19_28_58.logs.tar (251 KB)

I had the same problem with mine and solved it by doing what you did (except I used nano). For some reason, the “static routers=” gets wiped when setting static IP. For your second question (app showing offline), try clearing the cache in the app (Settings / Clear Cache). That worked for me

Thanks Mrmah96, clearing the cache did it for me to. Showing on the map as well now :smiley:

1 Like

Hello smokie, thank you for the logs.

From them, in fact, it appears that your Shake is performing as it should, and it is indeed visible on our network, which is receiving data from it.


Thanks also to Mrmah96 for the input!

1 Like