New SD Card starts boot then restarts before completing

My Shake has worked flawlessly but last week went offline. Assuming a corrupt SD card I flashed a new SD card with release 18.4. The boot starts OK (as indicated by LEDs or viewing HDMI output), but after a few seconds all LEDs go out and the boot process starts again. I have tried a) Different SD cards - 8 and 32 GB b) Burning the rshake_os.xz image with etcher c) Copying all the files and overlay sub-directory from the expanded .zip to a newly formatted (FAT-32) SD card and booting from that - this starts resizing the filesystem then reports “Re-reading the partition table Failed.: Invalid argument”. After a few repeats of that the system reboots. Any ideas on what I’m doing wrong / what’s going wrong? Or should I assume that the hardware has died in some way and just buy another one. Thanks

Hello robtech58, welcome to the community!

From what you are writing it seems that some kind of corruption is involved, or in the partitioning process or on the microSD cards.

I know that you already tried, but can you try again with the following procedure?

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

Let’s see if this will change something. If not, we will go towards a different approach.

Thanks for the reply. I have previously done all that, but did it again. I took a brand new 8G Sandisk Industrial SD card. Did a full format and checked the partition table - all good and capacity checked out. This time rather than expand the ZIP on my Mac and then copy the files across to the SD I copied the zip to the SD and expanded it there then deleted the ZIP. The shake then booted fine and I could see it on my network and reconfigured it. BUT - I then shut it down from the command line (I had a keyboard and monitor attached) and after a while turned off the power. On restarting the Pi started its boot but when the output on the terminal got to about 2.3 - 2.4 seconds the boot process stopped, all the LEDs went out and the process restarted. It keeps cycling through that some pattern. So in summary, I can create a SD successfully and have the Shake boot up and operate but a safe shutdown and restart causes the subsequent boot to fail and keep cycling. Any suggestions? Thanks

Thank you for explaining the entire process robtech, this is useful to understand what’s going on on your side!

I will contact our tech team to see what they can say to me about this, since it seems that the microSD cards boots completely fine at the start and then, for some reason, refuses to do it again.

I’ll update you as soon as I have news.

I’ve solved it. I swapped the Pi and got similar results so I swapped the power supply and that seemed to fix the problem. I’m not sure if the power supply died or a power glitch took it out. Should have started there but when you see something boot up once you assume the power supply is good. A good reminder that when there are complex symptoms it’s best to eliminate the simple causes first!


Great to hear that!

It is absolutely good advice to give, and thank you for sharing it with all the users on the community!

I ran into the same problem. I found that my power supply was also inadequate. During boot up it draws a lot more power than what the power supply can provide, and it would reboot before finishing the boot. Using a charger with more amperage or wattage solved my problem too.

The one included in my kit can provide 2.5 amps, but it doesn’t work if you want to use the HDMI connector at the same time.