New RSDUP install issues: PA display units; no Telegram notifications

I successfully installed RSUDP on Windows 10 desktop. Both EHZ and HDF channels display correctly, and audible alerts correctly sound when an EHZ event occurs. But, two configuration issues remain:

1). EHZ trace correctly displays y-axis units in Velocity (m/s). However, HDF channel y-axis only displays in Counts, not in PA units. How can I get it to display in PA?

2). Re: Telegram notifications. I’ve never used Telegram, so I created a new account and bot, and followed the setup instructions in Section 3.6.1 of the RSUDP guide. I have yet to receive any Telegram notifications when an alert occurs. All Telegram JSON settings appear correct in the .config file telegram field, i.e., enabled: true, send_images: true, token is correct, chat ID is correct, etc. I have the Telegram app on both my iPhone and Destkop, and they can send messages between themselves. Any suggestions on how to fix?

Thank you in advance and kind regards…Mike

Thank you in advance.

Hello mpan,

Let’s see, in order:

  1. Could you post here the content of your installation rsudp_settings.json (or attach the file)? Thank you.

  2. This issue is a known one (other users have reported the same problem) and the developer will be working on this for the next release of RSUDP. You can follow the progress here:

Thank you. Here’s my current JSON listing. Regarding Telegram, thank you for posting the link, and I’ll keep track of the progress.

“settings”: {
“port”: 8888,
“station”: “R86CD”,
“output_dir”: “C:/Users/myname/rsudp”,
“debug”: true},
“printdata”: {
“enabled”: false},
“write”: {
“enabled”: false,
“channels”: [“all”]},
“plot”: {
“enabled”: true,
“duration”: 90,
“spectrogram”: true,
“fullscreen”: false,
“kiosk”: false,
“eq_screenshots”: true,
“channels”: [“all”],
“deconvolve”: true,
“units”: “CHAN”},
“forward”: {
“enabled”: true,
“address”: [“”],
“port”: [8888],
“channels”: [“all”],
“fwd_data”: true,
“fwd_alarms”: true},
“alert”: {
“enabled”: true,
“channel”: “HZ”,
“sta”: 6,
“lta”: 30,
“threshold”: 3.95,
“reset”: 0.9,
“highpass”: 0.8,
“lowpass”: 9,
“deconvolve”: false,
“units”: “VEL”},
“alertsound”: {
“enabled”: true,
“mp3file”: “beeps”},
“custom”: {
“enabled”: false,
“codefile”: “n/a”,
“win_override”: false},
“tweets”: {
“enabled”: false,
“tweet_images”: true,
“api_key”: “n/a”,
“api_secret”: “n/a”,
“access_token”: “n/a”,
“access_secret”: “n/a”,
“extra_text”: “”},
“telegram”: {
“enabled”: false,
“send_images”: true,
“token”: “n/a”,
“chat_id”: “n/a”,
“extra_text”: “”},
“rsam”: {
“enabled”: true,
“quiet”: true,
“fwaddr”: “”,
“fwport”: 8887,
“fwformat”: “LITE”,
“channel”: “HZ”,
“interval”: 10,
“deconvolve”: false,
“units”: “VEL”}

Hello again mpan,

Thank you for the JSON. Everything appears fine and well configured from there, so the issue is explained by this point in section 3.2 of the manual: 3. Modules and Settings — rsudp documentation

For the time being, the Raspberry Boom will display in counts of Voltage, i.e., not a deconvolved unit.

If you want to display Pascal data instead of Counts, you will have to manually modify the plot function (rsudp.c_plot - rsudp.c_plot (plot data) — rsudp documentation) and divide the data to be plotted by 56000 (as visible in this other example Developer’s corner — Instructions on Setting Up Your Raspberry Shake) to obtain Pascals.

Or, you can open a new issue here (Issues · raspishake/rsudp · GitHub) and request for this feature to be implemented in a future release. However, there is currently no time frame for when it could be done, as rsudp is a software provided as-is.

Stormchaser…thank you for the quick reply. Will make for a good weekend project :slight_smile:


You’re more than welcome mpan.

If you make progress, please let us here in the community know, as I’m sure others will be interested!