New RS1D setup issues

I recently installed my first RS1D. Found out the hard way that pi4 is not/no longer supported. I am running it now on a pi2.
Once I got it running it showed up as “newest station” but it doesn’t show up on the station map. When I open swarm from my MAC (same subnet) it lists my RS1D, but doesn’t get any data. I crawled through the log on the pi but couldn’t see anything wrong at first sight.
Files in /opt/data/archive/2020/AM/RF7DA/EHZ.D seem to suggest it is doing something…
The local status page doesn’t show any issues.

How can I check if my shake is actually working?
Any reason why it doesn’t update on shakenet?
Attached the logs.RSH.RF7DA.2020-08-01T19 54 20.logs.tar (504 KB)

Not sure if it is related, but I changed the password of the ssh user back to the default and now I can see my station in swarm under the communities. Still not on shakenet and also not in swarm as “myshake” (I checked the swarm config and it seems to show the correct ip)

Have you tried rs.local on a chrome browser? It should come up showing your raspberry shake with a quick summary of what your shake is doing and you can also see the helicorder to see if it is recording data

Edit: Re-reading your post I realised you had tried it.

Accessing the shake with a browser works (I haven’t tried chrome, but firefox works as well). The status looks ok with forwarding enabled.
Since I reset my password to default I am getting results:
In swarm community it shows data, so I guess my first question (“does it work at all?”) is solved.
Local Helicorder data is shown when accessing it from the button in rs.local.

Swarm/myShake returns “no helicorder data” and also shakenet does not show any data (although it recognizes my station on my dashboard, but not in stationview.

How long has it been up for?

When I set mine up it was a couple days before it was visible on shakenet and before I could download or view data via the larger server that the data is stored on. Looking at your postboot.log in your log files, it hass completed the boot-up sequence so should be fine. Might just take a couple of days for you to access the data. @iannesbitt, can you provide more insight?

In terms of swarm, I’ve found that sometimes you need to close the helicorder window and open it again with the button in the bottom left, that sometimes works for me. With a local connection it should work fine. But, I’m afraid that’s where my knowledge/experience ends.

1 Like

Hello @hanger,

Yes, there was an issue with the OS version with Pi 4 support that caused us to roll back the update while we try to find and fix the bug.

Regarding the data transmission, from the logs, it seems that the ports 55555 and 55556 are closed for your network, and thus the Shake cannot transmit the data to our servers but it can be seen locally.

2020 213 17:02:59>> Connection request ( failed with error code: Connection refused

Could you try and open these ports using the Shake IP or MAC address that you already found find in rs.local, wait for 24h, and see if the problem is solved?

If not, please reattach your updated logs, so we can investigate further. Thank you.

In case you need it, the full ports list is found here:

1 Like

That’s good to see. What I encountered is that the SD card image did not include the required sofwtare for the pi4 and it therefore did not boot. Luckily my Pi2 booted without problems and seems to be working now (almost). The only open item is the local swarm connection. All other things are working. Thanks for your assistence.

1 Like

You are probably right. Now, 24h later it all seems to work. With the exception of the local swarm. The community swarm does work though. Enough to start experimenting. Thanks for your thoughts and sharing your experience.

1 Like

Hi @hanger, @stormchaser and I had some miscommunication, and the manual is for the moment incorrect. The Pi 4 is not currently supported because we found an issue with data acquisition and decided to roll back that OS update. Pleased to hear that the Pi 2 works, sometimes it can take several hours for the changes to propagate through the servers and appear on ShakeNet and other services. Thanks for your patience. When the Pi 4 version is re-released we will send out an update.

1 Like

Glad things seem to be working alright and glad I could help in any way I could.
Hopefully swarm will be behaving soon. If you’ve rebooted or unplugged your shake for any reason, it might be worth checking to see if your ip address has changed, unlikely but worth a check at least. If you use the rs.local as your ip address in swarm then that shouldn’t be the issue. Or possibly the port number is incorrect. I’m not sure though, just spitting out ideas.

1 Like


an update on Shake-OS 4 Model B support:

the Shake-OS image available for general download, found here, now provides full support for Raspberry Pi 4 Model B computers for use with all Raspsberry Shake seismograph types.