Network Unreachable error when trying to install package

#1

I wanted to install an FTP server (pure-ftpd) so I can routinely extract the data files from my Raspberry Shake system. The files can then be archived on my QNAP NAS box without having to increase the number of days stored on the SD card.

If I type apt-get install pure-ftpd then, after answering ‘Y’ to continue, I get several similar error messages that tell me I cannot “initiate the connection to mirror.us.leaseweb.net:80” … “101: Network is unreachable”

I tried the same command on a standard RPi3 and the command worked with no errors - but I could see that my system accessed different servers.

I checked the site: mirror.us.leaseweb.net and I get “unable to connect”.

If this mirror is down can I switch to another one (eg http://mirror.nl.leaseweb.net) or is this mirror something specific to RS?

#2

Not answering your question exactly, but I would note that Raspberry Shake does have ssh/scp already installed on it. You could put a line in crontab to scp the latest data file(s) over to your NAS every day. This is something I have had in mind to do on my own system for a while now … The advantage would be not having to install any new software on the RS itself. You do need an SSH server to be running over on the storage side, of course …

Or - you can use an ssh/scp client on the NAS side to pull the files over, if you have a way to configure that…

Ken

2 Likes
#3

Thanks for that information Ken. I like your idea of a cron job to push the data to my NAS. I also discovered that an FTP server service is already running. Next time I will read all of the manual ;-).

Overnight I was a bit suspicious that I somehow I had upset the RS software installation so I created a new SD card from scratch as a test. I ran a simple apt-get to install gpizero and the mirror error message still appears.

1 Like
#4

There should be no issue if you’d like to replace it with another mirror, but that mirror actually looks up to me right now.

$ ping mirror.us.leaseweb.net
PING mirror.wdc1.us.leaseweb.net (207.244.94.80) 56(84) bytes of data.
64 bytes from mirror.wdc1.us.leaseweb.net (207.244.94.80): icmp_seq=1 ttl=53 time=107 ms
64 bytes from mirror.wdc1.us.leaseweb.net (207.244.94.80): icmp_seq=2 ttl=53 time=112 ms
64 bytes from mirror.wdc1.us.leaseweb.net (207.244.94.80): icmp_seq=3 ttl=53 time=98.2 ms
^C
--- mirror.wdc1.us.leaseweb.net ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 4ms
rtt min/avg/max/mdev = 98.186/105.718/111.526/5.587 ms
#5

Yes, I just checked here and it is now ok. Thanks.

1 Like