Nano editor control key doesn't work with Putty in W11

Hi All… Shake newbie here
Just set up my USB stick for my Shake 3D using SSH and Putty in my Win11 machine.
That went well… until I tried to edit the startup text file with the nano editor
$/opt sudo nano /etc/fstab
Fail… but I have used nano before when directly connected to my other RPI’s so…
It must be a Putty setup issue with ctrl characters… CTRL-X just shows as ^X in the text.
I have to exit Putty to get out of the file edit. The errors I put in are not saved
RSH.RF592.2022-01-06T18_39_23.logs.tar (1.4 MB)
any quick suggestions?

also: in my SSH the Pi would only accept the default user and password.
I had changed my password using the rs.local/ application
Otherwise… things seem to be running normally… I’ve seen my first quake!

Putty now configured properly and the nano editor works as I remembered from long ago.
One site suggested using the -w flag for editing system files.
The -w prevents an automatic line wrap in an editing window which can confuse systems.
I turned off the Autowrap Initially On box to achieve the same purpose, AND
I set Local Echo to Auto rather than Forced ON, AND
I set Local Line Editing to Auto for good measure.
Now the left,up,down,right arrow keys move the cursor as they should
and the CTRL-X, etc commands do not show up in the file during editing.
Write a settings group that works for you to the Putty Default file and you can forget them again.

The SSH password is still stuck in its default settings, however.
I still need help with that.


Hello tenthwave,

Firstly, thank you very much for the instructions regarding PuTTY and Windows 11, I’m sure that they will be useful for many users in the coming monts, with this new OS being pushed to more and more PCs.

Regarding the password, have you tried to modify it from the rs.local/ page, then reboot the Shake, and then try to SSH again? Is the only accepted password the default one still?

hello Stormchaser!
my password has now been changed… don’t know why it worked this time
test sequence:
(1) logged into the Pi successfully with PuTTY using “myshake” and “shakeme”.
(2) logged into Config with rs.local/ -> change_SSH_password -> and verified that my old password hint was what I had entered the last time that I “changed” my password (myhint1).
(3) tried to “change_SSH password” with the wrong old password. That test failed. The hint was still (myhint1)
(4) successfully changed SSH password using “shakeme” as the old password. Received a message that “password was successfully changed” to (mypass2) with the hint (myhint2). I specifically did not reboot when I exited Config
(5) verified that I now needed (mypass2) to log into the Pi with PuTTY. All seems well.
(6) changed password again successfully (mypass3) and (myhint3) and verified it with PuTTY.
so… all is well… Here is my log. I still don’t know how the old password hint got changed in Config without actually changing the password from “shakeme”. That caused no end of confusion and repeated changes of the password with new hints every time. I can’t really say for sure that I received the “password successfully changed” in retrospect but the hints certainly changed. Perhaps a “password change failed” message should be added.
Thanks… my new industrial USB stick is blinking away so the Pi was successfully modified.
RSH.RF592.2022-01-08T15_56_42.logs.tar (1.5 MB)

1 Like

Hello tenthwave, that’s great to hear!

Thank you for again explaining what you have done step by step. I am not sure why the first password change was not accepted, while the second and third were, but your suggestion of adding a “Password change failed” message is sound, and I have opened a ticket for our software team so that they can explore it and maybe add in future OS releases.

Happy to see that the Pi is working as you wanted! Enjoy!