My Shake disappeared

On 7/30/2020 I got a email message “We have not seen your Raspberry Shake AM.R3BFD on stationView ( in 3 or more days.”

So I go down into my basement corner to find my shake has power from the UPS but the ethernet port (#16) on Netgear switch has no lights showing on the plugged in port (#16). I unplug my shake, wait 5 minutes, plug back in. Still no Ethernet lights for that port #16. Other ports are working. I plug into another free Ethernet port (#7)and the lights start blinking. I think problem solved…
I wait a day and still my shake is not showing on the Shaker net.
I then internally ping my assigned static port ending in .13 and it pings okay.
I then try “http://rs.local” and nothing comes up.
I unplug my Shake, put on a table and hook up monitor and mouse.
I watch it boot up., Seems to boot fine but after it gets to the Login and waits a few minutes I start seeing the attached errors start to accumulate.

I am presuming the original 8GB boot/memory card from the fully built 2016 Kickstarter unit has failed…
I presume I need make a new boot card from a new 32 Gb card as 8 Gb cards are not on any shelves around here.

Would that be Technical supports take on this ?


Hello Tom, welcome to the community!

Yes, from the situation you are describing (and thank you for the details), it seems that the microSD card has failed, or there are some corrupted files on it that are now preventing the Shake for working properly.

You can try to re-burn the old one, or if this still doesn’t work, you can acquire a new one (both 16GB, or 32GB are fine) and burn it with our Shake OS.

In any case, these are the instructions to prepare the new OS image:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

Update Status.
I formatted a new Sandisk 32 gb micro SD card and then downloaded from gitlab the Shake OS image to a Window 7 Pro PC. I then extracted the zip directly to the SanDisk 32 gb micro SD card.
I had a monitor and mouse hooked up my Raspberry Shake which was on a work bench. I then inserted the SD card and watch the Shake boot. This time the Shake just stayed at the login prompt without producing errors.
I then went to the PC, brought up FireFox and entered “http://rs.local” which brought up the Shake config screen. Finally progress.
I then changed the password on the Shake.
After reboot I went to network and changed to a static IP and used with the DNS as
I rebooted the Shake and the Shake was still offline.
I changed my Netgear router settings for port forwarding to make sure but it had worked previously before…

I rebooted everything (cable modem, netgear router, Shake) and the Shake still would not connect.
I thought maybe it was a “time” thing and it needed some time to get synced. A few days later it was still “Not Connected” by looking at the “rs.local”.
I then started to change the “Network” settings by trying different combinations. Still no luck.
I had to dig around at work to find a USB Keyboard to bring home and attached to my Shake so I could look at config files directly


What I had found by looking at “dhcpcd.conf” was that every time I used the “rs.local” to change the network it would make a new entry. I had around 15 entries with one right after another.
Static ip_address=
Static routers=
Static domain_name_servers=

or various combinations.
What the key here is “” which appears to be caused by using the “Network” settings in “rs.local” seems to be adding a static address which adds a “/” to the conf file line.
I used “nano” from the Shake command line to edit the “dhcpcd.conf” file and change to …

I used “cntl-O” to save then “cntrl-X” exit.
I tried to reboot by command line but the user login of “myshake” does not appear to allow this. I instead pulled the power plug and plugged back in after 15 seconds. After reboot the “rs.local” shows…

So it appears to be successful however my Shake is not appearing on the Shaker net yet.
Things I have learned…

  1. I got the fully built plug and play Shake as a Kickstarter back in 2016.
    it came with a 8gb Micro SD card. That card appears to have lasted 5 years before it basically ran out of memory space so it was generating write errors as it had no more room. I have replaced with a 32Gb card so it should last a little longer.
  2. The “Network” settings from “rs.local” appear to be broken as it was always putting a “/” after all my static settings attempts…
    Here is my log file is it helps…
    RSH.R3BFD.2021-08-10T11 14 12.logs.tar (1.2 MB)



Hello Tom,

Thank you very much for all the details you put in your last post, they will surely be useful to present and future Shakers!

I have reported your findings to our software team, so that, after reproducing the issue, they will be able to patch it and it (hopefully) should not cause such problems again.

Thank you!


I am so impressed by your post. Thanks for all of your details and for supporting us during the KS campaign. I am also impressed that your microSD card lasted 5 years! Back in 2016 we were shipping standard consumer-grade (TLC) cards. It was not until some of these (a handful really) failed that we moved to commercial-grade (MLC) cards. Wait! It has been 5 years…? OH, now that is grounding. Time moves quickly when you are having fun.

Cheers, branden

1 Like