My raspberry shake is not visible on station view

I received an email that my raspberry shake was not able to be seen on station view. I rechecked all of the connections, and it appears to have all lights where it should…but I’m still not seeing it on stationview. Help, please?

I have my raspberry shake in a school.

RSH.R3F39.2022-01-17T17_59_59.logs.tar (4.5 MB)

Hello jallenbach, welcome to our community!

Thank you for posting your logs. Your Shake is now visible and transmitting live data on StationView, here: RS StationView

Thanks for contacting us about this!

I have a similar problem: New shake, worked great for 10 days. Then I shut it down to make a backup of the SD card on my PC. When I powered the Shake up again, everything ostensibly works:

  • I can log on to rs.local
  • It shows it is Data Forwarding
  • I can see new data using SWARM to connect to it
  • Yet it has disappeared from the Station View (online and on my Apps)

RSH.RA925.2022-02-26T18_10_14.logs.tar (1.4 MB)

Hello janc, welcome to our community!

Thank you for posting the logs from your Shake. I could reach and see your unit on StationView here: RS StationView

Sometimes it may take up to 24h after a disconnection/reconnection for a Shake to appear/re-appear on our services. Usually, however, it takes definitely less than that.

Hi Stormchaser,
Thank you very much for your reply and advice.
My station is indeed back on StationView and my Apps.


You’re very welcome janc, enjoy your Shake!

It has happened again - my Shake is on the local network but has disappeared from the global map and the Apps. I attach the logs once again.RSH.RA925.2022-03-08T21_20_05.logs.tar (1.9 MB)

1 Like

Hello janc,

Thank you for the logs, I cannot see anything that could point to an error and I can also see the station back online on StationView: RS StationView

I assume that anything that caused is not there anymore, but you did good in contacting us.

Thank you for your comments.
After a period away, I found the unit to be offline again - I will upload the latest log files.RSH.RA925.2022-04-20T10_42_43.logs.tar (2.3 MB)

Additionally, when I run SWARM on my PC (which can communicate with the Shake’s webserver OK) it cannot get any data and the SWARM console window says: ERROR - Timeout connecting to rs.local:16032 in WWSClient.

I AM able to connect from my PC to rs.local:16032 using the psPing utility.

1 Like

Hello janc,

I can still see the Shake connected and live streaming data on our services as of today. Thank you for the logs, they showed some connectivity issues during the booting process that were however resolved by the end of it.

Have you done other operations in the last three days that may have solved this behavior?

Regarding SWARM, have you tried to to connect to the Shake using its IP address instead of rs.local? The IP address should ensure a more direct interpretation from Swarm on where to look for a connection, and possibly solve the problem.

Hello, my shake has been working solidly for months.
Just yesterday I shut it down and powered it down to fit a new power supply (5V 3A). After powering up, it shows as offline in Station View from my Apps. The home page reports:
System Status: BOOTING
Data Producer: OFF
Data Consumer: OFF
Offline Mode: OFF
Data Forwarding: ON
Server Connection: Not connected

I will upload the latest logs.
Thank you for your help.RSH.RA925.2023-02-08T21_40_02.logs.tar (3.7 MB)

1 Like

When a shake is disconnected for a while, it apparently can take up to 24 hours for it to re-appear in the dataview listing.

From your logs, it looks like it is working. The important bits:

NTP Running:

     remote           refid      st t when poll reach   delay   offset  jitter
 SHM(0)          .GPS.            0 l    -   16    0    0.000    0.000   0.000
 SHM(1)          .PPS.            0 l    -   16    0    0.000    0.000   0.000   2 u   26   64    3   41.242    3.423   6.093
 disorder.primat    2 u   17   64    1  149.114    5.757   2.004
* (   2 u   25   64    3   31.713   -3.777   4.058

Network info:

Network Info

  Stand-Alone Mode : OFF
       Ethernet UP : YES
           WiFi UP : NO
     DNS Available : YES
Network Accessible : YES
       Nameservers : file

Connection to rasberryshake server:

=== Shake Data Server ===
 Port 55555 : YES
 Port 55556 : YES

Looks like your IP address is: inet

The only thing a bit odd is in the postboot.log file:

2023 039 21:39:23: Unable to read Firmware version number off of Serial Port /dev/serial0 after trying for 15 seconds, cannot continue!
2023 039 21:39:23: Is the Pi computer connected to the Raspberry Shake Board?  Please confirm and try again.

That looks to me like the shake board may not be fully seated on the R-Pi pins???
You might want to (gently) try re-seating - or maybe wait for @Stormchaser to see what he advises.

Thank you very much for your prompt reply and assistance.

I left it on overnight - still nothing.
Then I decided to shut it down and try it with the old (original) power supply - and now it works!

RSH.RA925.2023-02-09T08_24_15.logs.tar (3.0 MB)

Status showing as running and connected.

Interestingly, the alternative power supply is 3 amp whereas the original raspberry supply is 2.5 amp - it has a USB-C termination whereas the PI takes a micro-USB.

Clearly, there is something in my alternative supply that makes the Shake board not work correctly!

Interestingly, the Shake board blue light was on in both cases and yes: I did re-seat the board to no effect.

Another mystery solved.