My new RS1D having problems RCFAD

I have this new RS1D and have a RS4D for well over 1 yr.
The RS1D is giving me problems.I will say it could be pilot error but I need you guys to check and see.
It connects with Jamaseis along with my RS4D ok but is like 30 mins behind.

In swarm my RS4D shows up I have to look in community and my RS!D AM.RCFAD is there but with lots of skips.
In shake net it shows up on the map but When I click on it.It says not online.

I have the config setup correct like my RS4D.
Data Producer ON
Data Consumer ON
Standalone OFF
Data Forwarding ON
Server connected ON
It is connected directly to my router not using wifi with it.

I tried the Shakenet app and it now shows up but keeps timing out.My RS4D does not.
Any help is sure appreciated.
LIke I said my money maybe on pilot error but Please check on your end to be sure.RSH.RCFAD.2020-08-27T15 26 43.logs.tar (4.0 MB)

Hello reelfoot1951,

from your logs (even if it seems strange, since you have another perfectly working RS4D on the same network, I assume) it appears that your RS1D is suffering from some Hard Resets in the NTP service (which takes care of the time synchronization).

If the NTP service doesn’t work, or stops working, then everything else along the data transmission line fails, except for some moments every now and then (around the 30 minutes mark) when everything is instead working fine. An example here from your station:


This is also seen in the log files at these lines:

2020 240 15:07:01>>	Time adjustment M0: HARD RESET.  This will result in a one-time time-tear.
2020 240 15:07:01>>	5.0: NTP Time (Init): NTP:	1598540821.244039536
2020 240 15:07:01>>	5.2: NTP Sync (HARD): VEL Before: 1598539922.980000019	After: 1598540820.983999968	Diff: 898.003999949

To ensure that you have a constant connection with the NTP service, I can advise you to set-up a Static IP with appropriate DNS servers, following these indications:

  1. The first doesn’t require logging into the Shake at all. Simply navigate to http://rs.local/, make note of the Shake’s IP address, then click on the Config gear to go to http://rs.local/config.

    Click on Network, then under Ethernet Settings, click on “Enable static IP”.

    Fill out the Static IP field with the address you copied from the front page.

    Fill out the DNS server field with a more reliable DNS service. OpenDNS is a valid choice, which is but you can also use Cloudflare’s new DNS service by entering or Google’s by entering

  2. For the more advanced option, SSHing into the Shake, using the same IP and DNS that you have chosen for step 1, here’s the guide on how to do it in our manual: Static IP — Instructions on Setting Up Your Raspberry Shake


checking your details, i see that you are providing your own RPi, which means you have made the connections to the board yourself? the log files indicate that the computer is intermittently having trouble reading data from the Shake board.

please verify that all the connections between all components from geophone to the RPi are intact and solid and check again.

and let us know if there is any change in performance.



Thanks for the help guys,
But I still have a problem.
I swapped out both of my Pi3 b+ to try and no change with my RS4D–RB537 and RS1D-RCFAD. So I put the ones back I was using in the 1st place.

Shakenet kept telling me my RS1D was off line and the android app did too but my RS4D was online and working fine.I have had no problems with my RS4D since I 1st hooked it up.

I even tried 2 new sd cards still same problem.

Even Jamaseis,when I tried it ,it says wrong info when I input the shake info like i always do, Never happened before either.
I have a infiltec running on it and it is fine but it is hooked to my computer not my router and works fine.
I am on cable internet,I think maybe I am having internet problems,Too many things not working right all of a sudden. Until now most everything was fine.It has been raining hard since last night and still is.Lots of rain,

1 thing that seems strange is all this happened when I 1st hooked up the RS1D but each day things were getting better then all went haywire. I have had it a a little over a week. I replaced the pi board with another new one and same problem. Both shakes are on the same network which i read does not matter.

With all this I still think it just maybe my internet service,
I am going to wait a few days to see what happens,

Thank you all again

My RS1D --RCFAD is still giving me problems.RB537-RS4D seems to b fine. In shakenet it shows both on the map.I click RCFAD and it says not online.

I have swapped pi 3b+ boards temp no change used new sd cards no change. Used wifi and straight to network no difference.

Dunno,I am not giving up just yet.The answer will come in time I hope.
Thanks to all again.

Hello reelfoot1951,

the station appears accessible, with constant data upload from StationView here:

and, as of now 16:25 UTC, the data iself seems comparable to your other station RB537 (seeing some breaks in the upload of this last one, however).


However, I can see that the data does not appear neither on the app or on the shakenet stream itself, which continues to be strange.

Could you post again the logs from the RCFAD unit please? Let’s see if there is something else that has been overlooked.

I just downloaded this.
I also installed a new sd card. Both RB537 and RCFAD are showing up in the phone app but still not online shakenet.It shows both shakesRSH.RCFAD.2020-08-31T16 56 44.logs.tar (3.9 MB)


from the logs, it appears that there are still some connection problems, but since the NTP (the timing) service and the data upload are fine (as of now) it is possible that your ISP is causing you these issues.

From the postboot.log also this emerges:

2020 244 15:55:01: Defining Station Name: RCFAD
2020 244 15:55:01: Station Name has changed, tarring previous trace files and removing references
2020 244 15:55:01: Tar file of last 7 days of former station's data can be found at /opt/data/TRACES.RB537. tar: Removing leading /' from member names
2020 244 15:55:03: Configuring SEEDLINK...

which shows the swapping you described between your 1D and your 4D. Those lines are what happens since the station name is based on the MAC address of the ethernet port on the Pi connected to the Shake.

Thus the system has recognised the station name change and saved in a zipped .tar file the last 7 days of data so that it’s not lost.

Thank everyone for the help.I appreciate it.
At the moment both are online and running.RB537 and RCFAD, I will give this another week and see if things get better or worse…

1 Like