Mount USB archive - did I do it right?


I followed here for how to mount an external USB for data storage. Everything seemed to work fine, and I ran Step 7 at that link to have it automate the mounting at startup.

How do I know if it worked?

After rebooting, I went to rs.local, and the main screen there only shows 4gb of storage. Should that update when the usb is being used as the data archive?

As I was looking up this problem, I saw here that 64gb drives may not work, which is what I have. I did not run into the issues that poster identified, and everything appeared to work just fine, or at least, I got the same outputs as what is in the first link from the manual about “How to mount a USB to store the waveform archive”.

Did it work? How do I know? Thanks!

When I run the command in Step 5, it seems to work, but I am not sure if that means the data is saving to the USB drive (basically, I just need it because I will likely end up using more than 4gb of space):

df -h | grep sda1


/dev/sda1        58G   57M   55G   1% /opt/data/archive

With a 64 gb drive, it looks like maybe it is mounted correctly, but only using 55ish gb of the total 64 for data storage?

1 Like

Hello rbalik,

If you haven’t had any errors during the mounting procedure, the external USB storage has been correctly set.

Now that some time has passed, if you execute df -h | grep sda1 again, you should see different values in the command output. That indicates that all your data is being saved on the external drive.

I think that the discrepancy between the 64 and 58GB can be related to this (from Support | Western Digital - SD as an example, but other manufacturers apply the same logic):

Why is the capacity of my device (as reported by many operating systems) different than the capacity that is listed on its label?

All SanDisk products include the total capacity, at an unformatted level, that is stated on the product packaging. For example, a 128GB SanDisk USB flash drive has a total capacity of 128,000,000,000 bytes at the unformatted level (where 1GB=1,000,000,000 bytes).

Definitions of a Megabyte:

  1. Operating Systems commonly define capacity as follows:

    • Kilobyte (KB) as: 2 to the 10th power (1,024 bytes)
    • Megabyte (MB) as: 2 to the 20th power (1,024 X 1,024 bytes = 1,048,576 bytes)
    • Gigabyte (GB) as: 2 to the 30th power (1,024 X 1,024 X 1,024 bytes = 1,073,741,824 bytes)
  2. Disk Drive and Flash Memory Card Manufacturers commonly define a MB as one million bytes (exactly 1,000,000 bytes) and a GB as one billion bytes (exactly 1,000,000,000 bytes).

SanDisk defines 1 GB as 1,000,000,000 bytes. Operating Systems define 1 GB as 1,073,741,824 BYTES.

Note: Some capacity is used for formatting and other functions and thus not available for data storage.

A portion of the total capacity is used to store certain functions including optimizations of the memory that support performance and endurance and therefore is not available for user storage. This is disclosed on our packaging and marketing materials when you see the statement “Actual user storage less.”

1 Like

I confirmed that the values are indeed changing, so it does seem to be working. Thanks!


That is great to hear rbalik! Happy to see that everything is working fine.

For anything else, you know where to find us.