Lost server connection, ports blocked?

New shaker here having some issues with my RS3D. I did the initial setup on the desk in our home office and had it up and running perfectly in no time. The trouble (no server connection) started the following day when I moved it out to its new home on my workshop’s concrete floor. Then about a day or so later I noticed that the system time was incorrect. I took a look at the log file and noticed that the unit couldn’t get internet time and port 55555 was being blocked. I suspected that either my modem or isp (AT&T) had, for some unknown reason, blocked the needed ports. I gave AT&T tech support a call and they remotely configured a passthrough on my modem using the RS3D’s MAC address. The passthrough didn’t work and I was forced to power down the RS3D by yanking the plug. I have to wonder if the cause of the passthrough not working was because I was unable (after many, many tries) to configure a static IP.
Appreciate any help you can offer.
Jon Rosenstiel

RSH.R0738.2020-09-11T12_39_13.logs.tar (1.6 MB)

Hello Jon, welcome to the community!

Thank you for posting the logs from your Shake. The issue does not seem to be the port, as of now, but good that you checked with your ISP, but the fact that your Shake does not find any internet connection at all from your workshop.

From the postboot.log file, these lines explain the issue:
2020 255 12:18:52: Network detection failed, unable to curl or ping common sites
2020 255 12:18:52: No internet connection found
2020 255 12:18:53: Network detection failed, unable to curl or ping common sites

This also happens around 4 to 5 minutes later, after, I assume, you yanked the plug and powered the Shake up again.

Can you check if the LAN cable (I am assuming that you have connected the Shake in this way in your workshop) works properly by connecting another thing to it, like a laptop?

If the NTP service (which takes care of the time synchronisation) doesn’t work, or stops working, then everything else along the data transmission line fails, and no data is uploaded to our servers, as I am sure you have reasoned.

Thanks for the quick response.

I took the Shake back to our office and connected it up like I had originally. (When it worked ok) This didn’t change anything, still no internet connection. I also tried another LAN cable, but that didn’t help either. What did work was connecting the Shake’s wi-fi to my iPhone’s hotspot. Tried it twice and it worked like a charm both times, correct time and the server connection was up. (See attached log file) But when I changed from wi-fi back to wired it was the same thing, no server connection, etc.

I fiddled around with the modem’s (Arris BGW201-700) passthrough settings for a while, but could get nothing to work. An internet search revealed that I’m not alone in having port forwarding issues with this particular modem. I’ve got a few more things I want to try with the modem settings tomorrow, hopefully I’ll find something that works.


RSH.R0738.2020-09-13T20_44_15.logs.tar (1.89 MB)

You’re welcome, no problem at all.

This is interesting, thanks for checking the LAN cables, so we could exclude that factor. We have indeed registered a connection to our servers yesterday, but nothing more after that, so this confirms your experience with your iPhone hotspot.

I can also see your station on the StationView map, but obviously, with no data upload as of now. Doing a quick search on your modem model I think I found the same issues you did with it.

You could also try to change the DNS on the Shake, as explained in this page on our manual, https://manual.raspberryshake.org/firewallIssues.html, to see if this solves the issue. I’ll add some more info below.

There are two possible ways: setting a manual IP and DNS in the http://rs.local web config, or adding a line to /etc/dhcpcd.conf in the Shake filesystem.

  1. The first doesn’t require logging into the Shake. Navigate to rs.local (which should be doable, since your Shake is getting a local address from your modem), make note of the Shake’s IP address, then click on the Config gear icon (high on the left) to access the configuration menu.

    Click on NETWORK, then under ETHERNET SETTINGS, click on “Enable static IP”.

    Fill out the Static IP field with the address you copied from the front page.

    Fill out the DNS server field with a more reliable DNS service. OpenDNS, which is, is a good choice. You can also use Cloudflare DNS service by entering or Google by entering

The second way, a bit more complex, in which you can keep your Shake on a dynamic IP (assigned by your modem/router):

  1. SSH into the Shake (guide here: https://manual.raspberryshake.org/ssh.html)

    Once you’re in, copy and paste these commands (this example is for Cloudflare DNS):

    sudo echo 'static domain_name_servers=' >> /etc/dhcpcd.conf
    sudo service dhcpcd restart

    Now make sure those changes took hold:

    nano /etc/resolv.conf

    The file should look like the following:

    # Generated by resolvconf

    You should not need to restart, these changes will take effect immediately.

I’ll continue to look into it, and if I find something I will update you. If you find something instead, keep us posted, since this could become something for future users reference.

Looking at the logs again and consulting with my colleagues, another thing to keep in mind is to check if

port 123

is open for TCP and UDP traffic in both directions on your modem. Possibly, you may have to contact your ISP again for this.

This port is used by the NTP time synchro service, which as written in my first answer, is essential for data upload to our servers.

Spent a fair amount of time yesterday trying to open the needed ports in my Arris BGW210 modem, but got absolutely nowhere. Then I ran across a thread on an ATT forum in which they were discussing port forwarding issues with the BGW210. The issue was that port forwarding would work for a while then suddenly stop. (My original issue) One of the poster’s in the thread pointed out that the BGW210’s flood detection settings are hard coded into the unit and unfortunately, the user has no control over them. So, it appears that the modem’s flood detection scheme didn’t appreciate what the Shake was asking of it and decided to shut down port forwarding. As a sidenote, while configuring port forwarding on the Arris, I found that ATT Uverse (Uverse TV) and the Shake both use ports 80 and 123.

To fix the port forwarding issue I’m going to get a router… should be here in a few days.

And thanks again for the help.



Thank you for the update Jon, it definitely sounds a complex situation with that particular modem.

Keep us posted with the router, I hope that this solution will work for you and that you can start using the Shake!

Finally got her working… and recorded two local earthquakes in less than 24 hours! (I’m in southern California)

Basically, what I did was return the Shake to its original configuration by reformatting the SD card and reinstalling the OS. For setup I followed the quick start guide.

I know my Shake stopped working because it could not connect with the internet time service but I’m not sure of the exact reason. Guessing it may be that my isp’s modem/router did not like the Shake having a static IP address or a different DNS address. Whatever the cause, the Shake now works great and I’m not going to touch it.



1 Like

Hello Jon,

I’m really glad to hear that now everything works fine and that you managed to catch your first earthquakes! You had a good idea in formatting and burning everything from scratch.

Evidently, there was something that wasn’t properly configured or became not compatible with your modem/router ISP network configuration.

Enjoy Shaking!