Job for rsh-data-producer.service failed because the control process exited with error code

Hi RS Community,

I have an issue with my RS4D Station R4F28. The station lost communication with the servers and after multiple restart attempts the “Server Connection” was still not connected. Burned the new OS V 0.20 onto the SD Card and ran it. The problem is the “Data Producer” and the “Server Connection” are not running.

Below is a screen shot of the problem. Also attached are the most recent log files.

RSH.R4F28.2024-01-05T04-21-16.logs.tar (709.5 KB)

Below are the details from SSH connection.
journalctl -xe.txt (5.8 KB)
systemctl status rsh-data-producer.service.txt (19.6 KB)

Any help will be greatly appreciated.


1 Like

Hello Trevor, welcome to our community!

Thank you for providing the logs and all the data related to this issue. It appears that, while the Shake boots up correctly in the first phases, then data is not processed in the right way, as these lines show:

2024 005 02:41:54>>	UU?BS?%?Qe?Emªc?
2024 005 02:41:54>>	Y????ÔU?ÙÂaW?ÁËQ?TYÿBS?%?QÁ?UUªY??U?ÙÂ,
2024 005 02:41:54>>		16209	397
2024 005 02:41:57>>	internal error: buffer overflow!  cannot process read data...

As you can see, there are errors mixed with some ‘gibberish’ that cannot be successfully interpreted. My first thought would be to check and see if the current power supply you are using is continuing to deliver a stable voltage between 5.0 and 5.2V and a current of at least 2.5A at all times, as a decrease in power could lead to data services interruption. If the data interruptions continue to happen, and if you have another Pi power supply that you know is in working condition, please try to exchange the current one with that, and see if the Shake now properly works for longer periods.

A second check that you can do is to see if all the connections between the sensor, the blue Shake board, and the Pi board are still solid and free from dirt or any other element that could compromise transmission. As usual, if you decide to disassemble the Shake when doing this, please make sure you are using proper ESD (ElectroStatic Discharge) protection (such as gloves, etc.), as electronics do not like static electricity too much.

As a last resort, and if all these checks come out as positive, then I would recommend re-burning the microSD card again (or using a different microSD) after formatting and erasing all its data/partitions first (you can use DISKPART for this as it is very efficient), and see how the Shake behaves with the newly installed system, removing potential issues derived from corrupted files. I will leave the burning instructions link here for your convenience: microSD card topics

Thank you for your collaboration.

@ Stormchaser,

Thank you for your response. I re-imaged the SD card and made sure the blue board is securely set on. This seems to have solved the problem. However, I think the power adapter must also be a cause because the red indicator light keeps blinking with no particular pattern to it. Read here ( Raspberry Pi 4 Flashing Blinking RED Led - Raspberry Pi Forums ) that the Red LED is supposed to constantly on if proper consistent voltage is being supplied.

I might need to replace the adapter if the problem arises again.


RSH.R4F28.2024-01-09T06-06-06.logs.tar (286 KB)


Hello Trevor,

No problem at all, and happy to have been of help!

If the red LED blinks every now and then, yes, the power supply needs to be changed as it is not delivering enough voltage. As you are keeping an eye on it, it will be easy to spot eventual problems on that side.