jAmaSeis Compatibilty Problem?

I downloaded jAmaSeis to run with my RS4D, however, I am finding that the jAmaSeis software capabilities are not functioning properly with my shake. While the jAmaSeis helicoder display looks good, there are issues when attempting to extract an earthquake event.

On the helicoder display it appears that the x-axis hour line/amplitude line is set at zero level (please see helicoder display screenshot attachment for reference), but when an attempt is made to extract an earthquake event, the amplitude line way off by an extremely large value of +16,500 (please see event extraction screenshot attachment for reference). This issue prevents the user from being able to extract, upload, and analyze event data, and in turn, making all other jAmaSeis features such as Event View unusable as well.

As part of using jAmaSeis with an AS-1 seismograph, the “trace level” is adjusted to zero level externally using the dial knob on top of the black box, and of course, there is no external black box to do so with the RS-compatible version. And, unfortunately, I cannot find nor do I see a means in which to internally adjust the trace value through the jAmaSeis RS-compatible version. I’m not aware of anyone else running jAmaSeis with their shake, so I don’t know if this is a problem on my end, a glitch in the program, or something was missed when developing jAmaSeis compatible for the Raspberry Shake?

Hi Michael, I have essentially zero experience with jAmaSeis, but what happens if you adjust the “Offset” field to -16500?

I thought of that too, and tried, but unfortunately, it wouldn’t work because the value is too great. When using jAmaSeis with the AS-1 seismograph, after setting the trace value to zero level using the dial knob on the external black box, the offset is used just as a means for adjusting fluctuations and “fine tuning” the value in trying to get precisely on the zero level.

To get a sense that there is something wrong, if you look at the helicorder display screenshot that I attached it appears that line value is at the zero level, but if you look in the very bottom left-hand corner at the Last Value it reads 14,398 and that is where the current “real” trace line value is displayed. Then, once you attempt to extract an earthquake event, the real trace line value becomes apparent as seen in the event extraction screenshot.

Are you aware of or can you find out who created/developed the RS-compatible version of jAmaSeis? Is it possible to go back to them with this issue?

Thank you!!!
Thank you!

Good morning Michael!

Please submit an enhancement request to IRIS.

There is a simple solution to this that would eliminate the need for using the hardward dial on the AS-1 even: just demean the signal before plotting it!

Yours, Branden

Hi Branden,

Yes, absolutely, I will contact IRIS today and keep you informed of my progress.

Thank you,


1 Like

I see the email was sent! I also engaged. Now we will see what they say :slight_smile: