Issue with Shake 4D data gaps, and data consumption

We’re having an issue with a shake 4D that was installed some time ago. I have attached the log files in the hopes someone has some insight. The shake is having what appear to be some gaps in data collection unless we’re reading the page wrong (see attached screengrab). We’re also seeing the Shake transmitting tons of data, it’s consuming roughly 5gb of data daily and we don’t have the shake setup for any data transmitting. I assume the only thing it should be talking to is us when we reach out to it. We’ve read that it should average around 7-10gbs of data with these features enabled but again we have disabled those features. We’ve had to setup throttling on our cell modem. We have this same device installed at numerous sites with the same modems and haven’t had these issues. The shake is connected to a verizon cell modem in the field and we’ve tried multiple modems. We also reformatted the SD card and reinstalled the OS and it went right back to repeating these issues. Any insight would be appreciated.
RSH.R71BF.2024-03-13T18_13_41.logs.tar (2.3 MB)


Hello ScottPilgrim, and welcome to the community!

Thank you for the detailed explanation of the situation and the logs that you have provided. There are indeed some errors in them, an example below:

2024 073 17:30:15>>	buf: {ÿ_k#I]??W?E?UkÔAúÿ_k?M?D[2W??Ë?AÀU
2024 073 17:30:15>>	'AA0JE
2024 073 17:30:15>>	X???E?J]?äL]ª

As you can see, errors are mixed with some ‘gibberish’ that cannot be successfully interpreted (that could be causing the issues you are seeing). My first thought would be to check and see if the current power supply you are using is continuing to deliver a stable voltage between 5.0 and 5.2V and a current of at least 2.5A at all times, as a decrease in power could lead to data services interruption and the gaps you are seeing in the Shake helicorder.

If the data interruptions continue to happen, and if you have another Pi power supply that you know is in working condition, please try to exchange the current one with that, and see if the Shake now properly works for longer periods.

A second check that you can do is to see if all the connections between the sensor, the blue Shake board, and the Pi board are still solid and free from dirt or any other element that could compromise transmission. As usual, if you decide to disassemble the Shake when doing this, please make sure you are using proper ESD (ElectroStatic Discharge) protection (such as gloves, etc.), as electronics do not like static electricity too much.

Now, regading data transmission, 5GB daily is an enormous amount, as an RS4D should be around 8GB monthly on average, as you have written. I have also seen that the Shake is configured to not transmit any data, as follows:

Station Info

Data-Sharing Mode : OFF
Data Server Conn : OFF

Do you have this Shake available in a lab for further data transmission tests or is it still in the field?

it is still in the field but could be recovered if necessary.

1 Like

Then I would recommend approaching this situation in two steps:

  1. Check the local in-the-field power supply at that specific Shake to ensure that it is in good status, and if not, change/adjust it to provide the constant required power to the instrument.

  2. If the power supply is good, then check the Shake hardware status as recommended in my post.

  3. Then, when the above has been solved, check if the unusual data transmission behavior continues. If t it does, then it would be beneficial to have the Shake in a controlled environment (and ease of access) so that more tests can be done on what is possibly causing this excess data totals.

Okay, thank you for the reply. I think we will probably recover the device and run some lab tests.


No problem at all.

If anything else is needed during/after your tests, you can write here and I’ll reply as soon as possible as usual.