Issue While Making Raspberry Shake into Standalone Data Logger

#1

Hello,

I recently bought a Raspberrry Shake 3D that I plan to use as a standalone data logger. First, to test it, I followed the start up instructions, connected it to the internet, and was able to gather data and view it in jAmaSeis. Also, I was able to change the password as per your recommendation.

Then I directly connected it to my computer via an ethernet cable and followed the instructions to ssh into the shake:

https://manual.raspberryshake.org/ssh.html

Then the instructions to mount a USB to store the data.

https://manual.raspberryshake.org/usbsds.html

When I unplugged the USB stick and tried to read the data, my computer could not view it because I had formatted the partition as an .ext4 and I am using windows. So I went back and tried to format as an ntfs or fat32 (what do you recommend BTW?) and was unable to communicate with the Raspberry Shake. I couldn’t get past the first step (ssh myshake@rs.local), and receive the error:

ssh: Could not resolve hostname rs.local: no such host is known

When I run ipconfig, it does recognize the connection and I am able to ping it (directly to the ip address given, not to rs.local). However, if I try to ssh to the ip address it says connection refused. I am not able to ssh in via Putty either.

Attached is a screen shot of the command prompt I discussed above.

The little green light is still flashing occasionally which according to this post:

https://manual.raspberryshake.org/burnSD.html#how-do-i-know-that-my-microsd-card-is-corrupt-and-needs-to-be-replaced

Implies that the microsd card is not corrupt.

When I plug the ethernet into the internet, it is not found on rs.local, and I have no way to view or communicate with the device.

Please help and let me know how to proceed.

Thanks,

Sam

#2

Hi Sam,

From the attached photo it looks like you are not including the user in the ssh command. Try
ssh myshake@169.xxx.xxx.xxx it should prompt you for your password.

Angel

#3

Hi Angel,

Thanks for the response. However, that does not work either. It gives me the same error, connection refused.
image
Any other ideas?

Sam

#4

Hi Sam, I have a couple of questions which may help narrow down the range of possibilities you could be running into.

  1. Are you directly connected to the Shake, or connecting through a router? From your first post it seems like you are connecting directly. My guess is that either something is wrong in your computer’s internet settings, or the Shake’s IP is not in the “discovery” range as explained here.

    Try configuring your computer’s IP manually by setting it to 169.254.8.11, then try to connect again with

    ssh myshake@rs.local
    
  2. Did you perhaps change the address to a manual IP when it was connected to the router?

  3. Is there a reason you can’t connect to it when it’s connected to the router and the internet? That way you don’t have to go through the hassle of connecting it to your computer directly.

#5

Hi Ian,

Thanks for the suggestions but still no success.

By the way, I have been using Windows 10.

  1. I am connecting directly to the Shake. I configured my computer’s IP manually and set it to 169.254.8.11, attempted to connect again and got the same error.


image

  1. I may have accidentally changed the address to a manual IP when it was connected to the router. Not sure.

  2. There probably is a reason that I can’t connect to it through the internet, but I do not know the reason. When I first got the Shake, I was able to connect via the internet, read data, and secure the shake per your instructions. This does not work any more, when I connect it to the ethernet in the wall, it does not show up on http://rs.local . However, my intent with the Shake is to turn it into a battery-powered, stand-alone device to deploy in the field.

Since all of the Raspberry Shake instructions are for Linux, I installed Ubuntu 18.04 using Windows Subsystem for Linux.

I then went through the procedure suggested for Linux and got the same error. I was not able to ping rs.local after setting the discovery IP. However, I was able to ping 169.254.8.11, but not able to connect to either. See the screenshot below.

image

What do you suggest I do next?

Thanks,

Sam

#6

Hi Sam, is it possible to connect the Shake to the router again and use Fing to find its address?

#7

Hi Ian,

I’m at a university and connected to their network. I downloaded Fing and there are over 1000 devices on the network. Do you know what it would show up as? I tried searching shake, myshake, raspberry pi, and raspberry shake and it didn’t find any of those.

-Sam

#8

hi sam,

i think there’s some confusion here. seeing now your screenshots, the IP address you are setting manually, 169.254.8.11, is the IP address of your windows computer, not the IP of the shake.

which quite well explains why your ssh command is failing, there is no ssh client running on your windows box.

when you plug in your shake directly to your ethernet port on your computer, try running the command:
ping 169.254.255.255
and see what that returns, it may resolve both the windows and pi computers so that you can see the IP of the shake Pi.

cheers,

richard

1 Like
#9

Hi Richard,

Thanks for chiming in. However, no luck.

When I have the Shake plugged directly to my computer via ethernet and run:

ping 169.254.255.255

No packets are received.

image

Any other ideas?

Sam

#10

Have you tried manually removing and reapplying power and retrying?

#11

Yes, I have disconnecting both the power cable and Ethernet cable and retrying

#12

hi again,

let’s take a step back and regroup for a second. we’ve iterated enough times now that i had lost the plot a bit, but i’ve resolved that after a fresh look from the beginning and have a couple of new recommendations that i think will resolve this.

but first, i want to restate the exact problem so that we are all guaranteed to be on the same page, that is:
when your Shake is connected either to the university network, or when connected directly to your computer, we need some method to find out the assigned IP address in order for you to be able to either log in to the Pi, or to pull up the front-end interface in a browser, so that you can access the Pi. (since rs.local is not working for you.)

Method 1 - Connected to University Network
in this case, running Fing produced too many results and you were unable to find your unit amongst all the noise. assuming you know the name of your station, you can limit the list returned by Fing by using the search function and providing a portion of the MAC address.

the Shake stations are named using the last four characters of the ethernet interface on the Pi computer. conveniently then, you can take the station name and reconstruct the last four characters of the MAC address. for example, when your station name is R1234, the last four characters of the MAC address will be 12:34, where you would use this for the Fing search. then, your list will become much shorter (most likely even returning only your specific Shake) and your unit will be easy to identify.

Method 2 - Connected Directly to your PC
in this case, since you have installed the Linux sub-system on your Windows machine, you have the program tcpdump available to you which can be a big help. execute the following steps and see if you are able to see the IP address that is assigned when connected directly (each of these done in a Linux window):

  1. run ifconfig to determine your ethernet interface name (and unless it has changed from when you did this before, it’s still eth1)
  2. in a Linux window, start a tcpdump command like so:
    > tcpdump -n -i eth1
  3. reboot the shake, in this case a hard power-down and -up
  4. back to the Linux window and you should start seeing data packets where the Pi is attempting to find a DHCP server, which will fail, ending with it assigning its own IP address.

whichever method you use, the IP address found is what you should use to either connect to it using:

  1. > ssh myshake@ip.address
  2. how to construct the URL in a browser to run the front-end interface program, http://ip.address

when these don’t work for some reason, my next suggestion would be to take your unit home with you and connect it to your local LAN there, i will imagine in that case that Fing will return something less than 1000 connected devices on your router!

please let us know how this goes.

cheers,

richard