Initial setup default password

I am trying to do the in initial set up (AM.REF7D.00.SHZ) but every time I try to save the configuration I get an authorization failure using the default password. I have tried 3 different browsers (fedora) with the same results. Any ideas?


Can you try ssh’ing into your box with the default password? This will confirm the current password is still the default one.

Looks like you are on Linux so open a terminal and input:
ssh myshake@rs.local
and follow up with the default password ( shakeme ).

Tried your suggestion, password still failed. Everything appears to be working properly so I don’t thing it is a corrupted disk. Can I mount the microsd on my linux system and manually set/reset the password?

Thanks for your help

Alright, so it’s no longer the default password then. The usual solution here is to restore your microSD with a fresh image and start over again, but if you feel confident in trying to reset the password manually, by all means do so.

I’ll ask around to see what could possible cause this. If you have any issues with restoring a fresh image, feel free to ask for guidance.

Restored the microSD from the downloaded image (v0.15). Now the console will accept the password. I changed it and the new password worked at the console. The password still fails at the browser and via ssh.

Is there any log I can look at to see what is coming through on these failed logins?

Is there any setting changes I can make from the console?


BTW - the MD5SUM didn’t match the published value???

[ctimmer@localhost Documents]$ md5sum r*.zip


Hi Curt

Would you mind explaining what exactly you mean by console? I thought this meant SSH’ing with the terminal, but it seems like I was wrong.

After restoring the image, did you try to SSH or access the web app with the default password? How did you change the password?

Sorry for all the questions, but I am trying to get a good grasp of what the exact situation is.

/var/log/auth.log should contain login attempts, but if it’s because of a wrong password, there most likely won’t be a lot of helpful information in there.

Console - To restore the rs image I had to attach a monitor and keyboard to the raspberry pi. After restoring the rs image, I was able to login to myshake using the default password with the keyboard. I was not able to authenticate (with the default password) remotely on the web interface or via ssh:

[ctimmer@localhost Documents]$ ssh myshake@rs.local myshake@rs.local's password: Permission denied, please try again. myshake@rs.local's password: Permission denied, please try again. myshake@rs.local's password: myshake@rs.local: Permission denied (publickey,password). [ctimmer@localhost Documents]$

I then changed the myshake using ‘passwd’ and verified I could still login on the local keyboard. Remote access still failed as before, with the new password.

Don’t worry about the questions, I want to get this fixed too.


Let’s try a couple things to see if we can narrow down the issue.

  • Can you try SSH’ing using the IP and not rs.local ( best to get IP using ifconfig on the console )
  • When you’re saving the configuration on the web app, can you open developer tools in your browser ( usually F12 ) and check the network tab for calls made to /api/config, /api/restart or /api/reboot. Make sure to open the tools before saving, and take a screenshot or copy the results of the calls here. You should be getting 200 response statuses across the board if everything is alright.
  • The web app depends on a Python module called Pamela to authenticate a user. You can test this by opening the Python interpreter ( run python ) and typing in the following:
    import pamela
    – `pamela.authenticate(“myshake”, “your-password-here”)
    If it works this will run without returning anything, otherwise it will throw an exception ( you can test by putting in a wrong password ). See if it works for your password, copy-paste any potential exception you get here.

Hopefully this will allow us to pinpoint the issue. Thank you for your patience and cooperation.

Well, this is embarrassing. I had a RS a few years ago that quit working and I gave up trying to fix it. Unfortunately it was still plugged in to the network and this is the device I was connected to. Sorry for the trouble and thanks so much for the help.



Does that mean that your Shake is now online and streaming?

Yours, Branden

Yes, both R8A9B (new) and REF7D (old) should now be streaming data. I loaded the latest release on my REF7D and that seemed to fix whatever the problem was.

One more question: I ordered some industrial grade SD’s. Would you recommend copying the current shake image or doing a complete new installation? The SD’s are bigger (16G).

Thanks again,


I recommend a complete new installation.

Yours, Branden