Incorrect time and date

Hi, it seems that my RS 3D is not getting the correct time and date, I have followed the instructions on https://manual.raspberryshake.org/firewallIssues.html?highlight=ntp to get more info and this is what I got:

I do have an active internet connection and the gps seems to be working correct, follow the log files.

RSH.RA30D.2020-09-24T12_15_00.logs.tar (1.7 MB)

Hello Pablo,

Thank you for the logs and the screenshot. It definitely appears that your RS3D cannot manage to find a server and thus no NTP connection. If the time delta exceeds 45555 seconds (around 12 hours) then the data are not uploaded to our servers.

From the postboot.log file, these lines explain the issue as a DNS problem, as if only with the LAN cable the Shake cannot reach the online servers:

2020 268 12:11:11: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available
Job for ntpdate.service failed because a timeout was exceeded.
2020 268 12:12:11: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available
2020 268 12:12:13: No internet connection found

There are some procedures that you can try.

—> The first thing you can try, if you haven’t already, is simply to shut down your modem/router, wait a couple of minutes, and then turn it on again, to see if it was a simple issue with the modem/router itself.

—> The second is to check that the port that takes care of the NTP service,

port 123

is open for TCP and UDP traffic in both directions on your modem. Possibly, you may have to contact your ISP again for this. If you have to open it, please restart both your modem/router and the Shake afterwards, so the changes can be successfully detected.
If the NTP service (which takes care of the time synchronisation) doesn’t work, or stops working, then everything else along the data transmission line fails, and no data is uploaded to our servers, as I am sure you have reasoned.

—> If these first two options do not solve the problem, then you can also try to change the DNS on the Shake, as explained in this page on our manual, https://manual.raspberryshake.org/firewallIssues.html#how-to-manually-change-dns, to see if this solves the issue. I’ll add some more info below.

There are two possible ways: setting a manual IP and DNS in the http://rs.local web config, or adding a line to /etc/dhcpcd.conf in the Shake filesystem.

  1. The first doesn’t require logging into the Shake. Navigate to rs.local, make note of the Shake’s IP address, then click on the Settings gear icon (high on the left) to access the configuration menu.

    Click on NETWORK, then under ETHERNET SETTINGS, click on “Enable static IP”.

    Fill out the Static IP field with the address you copied from the front page.

    Fill out the DNS server field with a more reliable DNS service. OpenDNS, which is 208.67.222.222, is a good choice. You can also use Cloudflare DNS service by entering 1.1.1.1 or Google by entering 8.8.8.8.

The second way, a bit more complex, in which you can keep your Shake on a dynamic IP (assigned by your modem/router):

  1. SSH into the Shake (guide here: https://manual.raspberryshake.org/ssh.html)

    Once you’re in, copy and paste these commands (this example is for Cloudflare DNS, but you can put your choice of DNS addresses):

    sudo echo 'static domain_name_servers=1.1.1.1 1.0.0.1' >> /etc/dhcpcd.conf
    sudo service dhcpcd restart
    

    Now make sure those changes took hold:

    nano /etc/resolv.conf
    

    The file should look like the following:

    # Generated by resolvconf
    nameserver 1.1.1.1
    nameserver 1.0.0.1
    

You should not need to restart, these changes will take effect immediately, but if you want, you can still do it.

HI!!!

Just here to inform that the static IP with google DNS worked perfectly (changed from rs.local).

Thanks!
Pablo b. Pizutti

1 Like

Hello,

Perfect, happy that I was able to help you Pablo.

You’re welcome, and enjoy Shaking!