I seem to have two "different" RS1Ds: One works, the other doesn't

Any suggestions about this?

I bought two RS1Ds, and they look different, and one works (i.e., connects to internet), and the other doesn’t. See attached, and notice that they look different and have different ports.

Indicator lights:
Red, Blue - On for both.
Green (Sort of Yellow?): Flashing slowly for both.
Lights where Ethernet cable is connected - On for both, flashing for the one that works, not flashing (just on) for the one that doesn’t work.

The one that works looks the same as many others that I have. I don’t think I have ever seen one like the one that doesn’t work.

Any thoughts about this, why they are different, and how to get the one that isn’t working to work?


Hello kafka,

Thank you for the LED indications, they are a good reference to what may be happening.

If the green light on the LAN port is not lighting up, then there could be issues caused by microSD card corruption that would prevent connection, as I assume that you have already tried swapping LAN cables to see if that was the reason of the inability to connect.

In such cases, the fastest way to solve this would be a fresh microSD re-burn of the Shake that doesn’t find an internet connection. I will leave the burning instructions here for your convenience:

Once done, the Shake should be able to boot up and connect with no issues. But, if there are any other problems, I remain available.


I will burn a new card. I have successfully done that before, so hopefully that will be straightforward.

Is there a particular SD card that you recommend?

But: I’m still curious. Is this a new design for the RS1D? Why does it look different from all of the others I’ve worked with?

You can still use the same one that is now not working to start with, but if you want to try wiht a new one, we recommend against using consumer-grade TLC microSD cards with Raspberry Shake, as they can get corrupted fast. Use commercial-grade (MLC) or industrial-grade (SLC) microSD cards instead.

Any size is viable, but remember the proper formatting as indicated if the microSD capacity is larger than 64GB. More info on microSD cards can be found here in our manual: microSD card topics — Instructions on Setting Up Your Raspberry Shake

Regarding the differences, are you referring to the different appearances of the HDMI ports on the two Pi boards? I think that those are newer boards that support microHDMI connectors instead of a single, larger, HDMI one.

OK. Thanks! All of that sounds straightforward enough. I will get to working on it over the next couple of days, or so.

One more question:
Are you aware of any instrument response/calibration differences with this new RS1D? I want to make sure that it is designed to be the same instrument response as the other RS1Ds in my RS network (at Boston College/New England)?

No problem at all!

All the instruments of all Shake models are calibrated to offer the same performance so that, if you have many Shakes in the same network, you can be assured of their efficiency.

Once this one is good to go, you will be able to integrate its data with the others’ without issues.


I formatted a new SD card [16GB, formatted as FAT(32)], downloaded raspishake-release.zip, unzipped it, copied the unzipped files to the new SD card, and inserted the new SD card into the Shake, and:

It’s still not connecting to the internet, and I don’t see it on Fing.

Red, Blue - On
Green: Flashing slowly
Lights where Ethernet cable is connected - On, not flashing.

Any suggestions?

Hello kafka,

At this point, I would try to shut down everything, both Shake and modem/router. Then, turn on the modem/router and check that everything is working fine with your other devices connected to it (i.e., that you can connect and navigate the internet).

Now connect the Shake directly to the modem/router with the provided cable (or, if you have another CAT6 or superior cable, please feel free to try that one too) and check if the Shake gets assigned a proper IP address from the modem/router and is visible on its administrator panel, or maybe try again with Fing. Also try different LAN ports on the modem/router itself.

If none of the above works, then try to execute a direct connection between the Shake and any PC/laptop that you have available, remembering to set your PC/laptop IP address address to be in the same range of the Discovery IP of the Shake.

More information about this is in these two pages on our manual:

Once the IP has been set, hopefully, you will be able to ‘see’ the Shake and ping it with ping rs.local via command line. One of the lights (the green one) should be active and flashing, the other (orange) should stay on but static.


I connected the Shake directly to Ethernet on my laptop, and got this response:

(base) kafka@geakm4312adevl ~ %
(base) kafka@geakm4312adevl ~ % sudo ifconfig eth0 up
ifconfig: interface eth0 does not exist
(base) kafka@geakm4312adevl ~ %

And, without eth0, got this.
(base) kafka@geakm4312adevl ~ % sudo ifconfig up

Tried password I use to log on to my laptop (it’s a Macbook Pro), and that didn’t work.

Hello kafka,

With these results, it is possible that the LAN adapter on your Mac is named differently. Sometimes LAN is also found as en0.

Could you please execute the single ifconfig command, and post the output here, so that we can verify the above? Thank you.

This worked up to the point of accepting my password, but I still don’t see the new Shake on Fing.

sudo ifconfig en0 up

ifconfig output:

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
inet6 ::1 prefixlen 128
inet netmask 0xff000000
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
nd6 options=1
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
ether c8:bc:c8:d3:79:e8
inet6 fe80::cabc:c8ff:fed3:79e8%en1 prefixlen 64 scopeid 0x4
inet netmask 0xffffff00 broadcast
inet6 2601:183:cb00:2:cabc:c8ff:fed3:79e8 prefixlen 64 autoconf
inet6 2601:183:cb00:2:d968:f6f4:9998:daff prefixlen 64 deprecated autoconf temporary
inet6 2601:183:cb00:2:fc6d:b267:7c2c:c6aa prefixlen 64 autoconf temporary
nd6 options=1
media: autoselect
status: active
ether c8:bc:c8:92:84:01
inet6 fe80::cabc:c8ff:fe92:8401%en0 prefixlen 64 scopeid 0x5
inet netmask 0xffff0000 broadcast
nd6 options=1
media: autoselect (1000baseT )
status: active
lladdr 78:ca:39:ff:fe:30:33:2a
nd6 options=1
media: autoselect
status: inactive
ether 0a:bc:c8:d3:79:e8
media: autoselect
status: inactive

Hello kafka,

Thank you for confirming the LAN adapter label with the ifconfig command. To set up the direct connection you have to use the following, then:

sudo ifconfig en0 up

And see if you can ping the Raspberry Shake as indicated in the manual guides.

As the situation is unusual, if this test doesn’t provide positive results, I would try to install the operative Raspberry Pi OS, and see if the green light on the LAN port blinks when the Shake is started up. To do so, please re-format the microSD card and then proceed to install the Pi OS using the dedicated imager: Raspberry Pi OS – Raspberry Pi

Thank you for your collaboration!

Thanks. We are working on this.

In the meantime, I might be starting a new topic RE another Shake that keeps shutting down without any intervention from me. Will be working on testing that first, before I write for help.

1 Like

No issue at all kafka, I will help in any way I can, as usual.