How do I change rsudp plot units?

Every time I start rsudp I always get a plot of “Voltage Counts”. I’m hoping to display “velocity” or “acceleration” instead.

Edit 1: I managed to change it to “Velocity” by copying what you did in your tutorial: setting “station” to “R3BCF”. But how did that manage to change the units?

Edit 2: By changing the station to the station name appearing on rs.local (R258C), I’m no longer able to display velocity or acceleration. Why is that?

Edit 3: I’m making a prototype. Is it possible to clone rsudp and modify its source code then have it run? Or at least find the location where rsudp is intalled and modify it from there - that would be easier.

Edit 4: Found it. It’s under one of anaconda’s environments. But is this advisable? Editing the source files under that location.

If the station name is set to “Z0000” as it is by default, rsudp won’t know which station metadata file to download from the server. Setting it to “R3BCF” won’t work universally, because there are some checks to make sure the number of channels lines up, since the metadata file contains some math used to convert counts to metric units.

This is because R258C is not forwarding data to our servers, so no metadata file has been generated there yet. In order to deconvolve the units, the server has to be able to provide the response curve that will let rsudp do its math. Turning on Data Forwarding in the rs.local web front end (and waiting a few minutes for the server to catch up) will solve this problem.

Technically no, although it will work. The standard way of doing this is either cloning the repository (mkdir -p ~/bin; cd bin; git clone and editing it locally, or by forking the repository to your own github account (i.e. a copy would be made to which then allows you to clone it and save your changes to github).

Once you’ve made the changes to the code in ~/bin/rsudp, install it to your anaconda environment by doing, for example:

conda activate rsudp # make sure you're in the right environment
cd    # this avoids weird pip conflicts when your pwd is ~/bin/rsudp
pip install ~/bin/rsudp # install modified code

Hope this answers your questions. Cheers, I’m happy you’re experimenting with it!

If leaving the station name to “Z0000” can I still use the alert module and set thresholds using VEL or ACC?

No, as with any deconvolve operation, the software needs to have metadata that will tell it how to deconvolve the data. The only way to do this at the moment is to rely on station metadata from the Shake FDSN server.

I see. Because I’m planning to use my rshake with no internet. So I have to rely on the voltage levels when using the alert module?

In theory you could download an inventory file for your station and rewrite this line to grab that file from the local machine instead. That functionality is not currently built in.

I see. Where can I get this inventory file?

Do you have any tips on setting HP, LP, STA, LTA, and threshold when I’m aiming to detect a magnitude 3.0 and above earthquake? By the way I’ll be doing this on a shake table.

This is outside the realm of free technical support. We would be happy to help you via a paid technical support incident.

Aw I see… even on the tips for configuring the alert module?

It’s an extremely multivariate problem, but we have some example configurations at

Note that these docs are not yet complete, but the information here is a useful guide to at least get started.