Help Needed to Autostart swarm on Raspbian Linux with pre-configured options

I am trying to get swarm to autostart, full-screen, using a saved layout of my creation.
So far I have it starting, but swarm is ignoring my layout choice and isn’t loading full-screen when it does start.

Thank you!
Here is the screen as I’d like ot automatically open to…

1 Like

Hello Robert_Leonard, welcome to our community!

That is a very cool setup for SWARM!

I don’t know about the full screen, I don’t think that that option is available (but if someone else knows differently, please correct me). However, it is possible to save a layout and then auto-load it at the start of the program.

With the layout as your image shows, please go to the up left and click on the Layout menu. Once you have saved it with Save Layout, please select the Auto-load layout option so that a tick mark appears next to that element in the list.

Now you can close SWARM, and when you reopen it, it should automatically load the last layout that was saved/left open.

I am speaking from a Windows10 point of view, where this procedure works. There may be slight differences with a Linux-based OS.

Another tip from my instructions on how to make a kiosk here:

is to set the variable “kiosk” in the Swarm config file to the name that you gave to the data source in Swarm, and after a semicolon, your RS station name as displayed in the directory tree or helicorder in Swarm, eg. kiosk=yourshake;R1234 SHZ AM 00

After you’ve created and saved the layout and config you want on the kiosk screen, you should set saveConfig=false so that it can’t be changed until you reset this variable to true.

There are other instructions on that page to also set up a RPi so that it always recovers to auto-start up Swarm in kiosk mode with your config after power outages or other ungraceful shutdowns.


You’re right, I had forgotten about the availability of kiosk mode for SWARM.

Thank you for your useful contribution rock_jockey!