GPS Antenna

I have some difficulties with my GPS antenna.
I followed the instructions given by the manual.
The antenna is connected at the RS RC78F USB port and placed in the garden, with a good opening towards the sky, and the red led blinks regularly.
But ntpq -p returns a log file indicating that the GPS is configured but not connected.

I hope you can help me…
(ntp.conf and log files are sent as an attachment).

ntp.conf (2.3 KB)
RSH.RC78F.2020-01-12T02_01_31.logs.tar (3.3 MB)

the command cgps -s gives nothing :cgps


the cgps output definitely indicates that the GPS module is not providing data to the computer. the log file gpsd-mgr.log also indicates that it cannot find the the USB device.

so it appears that the USB connection is at fault, nothing wrong with NTP.

i do see that at the end of November last year, it was successfully receiving data from the GPS module, so it has worked in the past.

verify the USB connection, and when that’s okay, maybe something wrong with the GPS cable?

sorry i can’t be of more help,

Hi Ivor,
Thanks for your help.
Indeed, the GPS antenna worked well in November. I then left the station on an isolated island until January 5. During this period, the internet went down, and I was no longer receiving data. I thought they were nevertheless stored in the RShake.
when I got the RSHAKE on January 5, I realized that there was no data stored and that the time was incorrect.
I made a first test this afternoon .
I plug my RS GPS antenna on my laptop USB port .
then I installed Prolific PL2303 driver on my laptop; The GPS antenna was on COM3, and the chip was a PL-2303 HXD.
Then I downloaded U-center software, and scanned port COM3 : I managed to obtain latitude, longitude and time correctly. The GPS antenna is working well.
So I conclude that the problem is in the RShake (or USB connector)

I will keep on testing.(connecting a USB device on Rshake)

second test :
I connected my USB drive to the RS USB cable…
fdisk -l
mkdir /media/usb-drive
mount /dev/sda1 /media/usb-drive
cd /media/usb-drive
ls -l
File list is correct.

so, usb connection is working well

I did all the possible tests: cable, connectors, antenna.

any suggestion ?


Is it possible that the default TCP/IP port (2947) for gpsd has changed ?


when you have the GPS module connected, can you send along the output of the following command:

> ls -l /dev/ttyUSB*



there is not any ttyUSB.


With or without the GPS module connected, the lsusb command returns the same log.
I think the GPS serial interface is down. Could you confirm ?

yes, with the USB plugged in, you should see an additional line in the output of the lsusb command.

mine looks like this when i have a GPS module plugged in:

myshake@raspberryshake:/opt $ lsusb
Bus 001 Device 004: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
myshake@raspberryshake:/opt $ 

you should try to determine if it’s the USB or the GPS. try to plug something else into the USB port (e.g., a wifi module) and see if you get the same (non)-result, or if you can see it.

and, if you have a 2nd USB port, try to connect to that one as well.




I tried to connect my GPS module on a Dell Computer, and the serial port of Prolific Technology was recognized

Bus 001 Device 004: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 001 Device 002: ID 413c:301d Dell Computer Corp.
Bus 001 Device 003: ID 0bda:0184 Realtek Semiconductor Corp. RTS5182 Card Reader
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

I will try the test of my RS USB port this evening.



I just did a test with a USB-to-serial DB9 cable connected to my Shake USB port : the serial port is recognized.
to sum up, I don’t understand anything !!!

My GPS module is recognized by my Dell computer and not recognized by my Shake, but a serial DB9 cable is recognized both by the Shake and by my Dell computer !


hi olivier,

this is indeed a strange result. do you happen to have another Pi that you can try with the same SD card? and if that still fails, try with a different SD card and a new burned image?

i’m not really sure what more to suggest at this point since the tests so far have not succeeded in identifying the source of the problem yet.

warm regards,


Hi Richard,

I have a second RS 1D in a seismic vault in my garden. I will try to connect the GPS module on its USB port first.
The last solution as you stated will be to burn a new image on a SD card, but I will really do it as a last resort.


Hi Richard,

I believe that the problem is solved. I connected the GPS module on my second Raspberry Shake RF737, and the serial interface of the GPS module is not recognized either (the lsusb command does not return anything, when it should)
It is therefore the GPS module which has a defect. I will try to find one there. Unless it is under a one year warranty (purchased in August 2019) ?



We will send you an email. We will happily replace your GPS antenna!

Thank you for all of the troubleshooting. We try to understand all problems down to their root causes and very much appreciate your time.


Hi Branden,

I tried to reply to your email, but my message was spammed by
My address is correct.
Thanks for replacing my GPS module.

regards from Tahiti,

1 Like