FYI - Intermittent connections - Work done to roof

I wanted to share this to the community as an FYI is you are having work done on your house/garage and this is close to the vicinity of the work. I had new shingles installed on Wednesday to my house and garage, this caused so many vibrations due to the weight of the shingle bundles being put on the roof and the constant hammering and banging that goes on with a replacement of the shingles. I was curious the next day to see what the shake picked up and only then did I realize the connection issues that happened as a result of this excess.

For context, my shake (RD11A) is on the garage floor (concrete slab) and with weights on it to help couple it to the ground.

Here you can see the crew showed up around 1230 UTC but didn’t really start on the garage where the shake is installed until around 1400 UTC

When I noticed the issue, I tried restarting the shake via web interface but that did not solve it. I then shut it down from the interface hoping that would let the device settle and maybe come back to normal, which it did not. I ran a ping test for few minutes to see if it was something with my network but did not get any failed packets for lag spikes. This led me to do one last test, the hard rest at the device. While plugged in and running, I removed the USB power cable and let it sit a minute (I know not the best practice), but after this it came back on and kept a good connection.

You can see when I powered it down via web interface, around 20:00 UTC, and let it sit until I powered it back on around 22:00 UTC, and then when i went to the device and removed the power usb cable around 00:30 UTC.

If anyone else has seen anything similar, I would like to hear too and see if this is just a coincidence or if the vibrations actually did play havoc on the shake.

Hello Rich, welcome back to our community.

These gaps paired with the roof work you have described are an interesting coincidence indeed.

Two things:

  1. Are the gaps appearing also in the helicorder files created by the Shake itself? Could you access rs.local/ and click on the Helicorder icon in the lower left. Once in the Recent Helicorder Displays page, could you select the one(s) that matche(s) the day and time of the roof work and post them here?

  2. Could you please download the logs from the Shake and post them too? If you require, instructions on how to do so are on this page: Please read before posting!

Thank you.

I did look at the helicopter display and it shows the same gaps in data as seen here:

The display before:

The display when it began:

Display after:

Display when reset

Theog file is also attached here:
RSH.RD11A.2023-02-10T23_16_33.logs.tar (2.9 MB)

As I mentioned in the original post, once I did the power off with the connector and plugged it back in, everything went back to normal.

Just out of curiosity, i looked at the oldest helicoder display from feb 4 and it does show gaps too, but not as significant, orr constant as the latest incident. I chocked these up in the past as bad network connectivity, and as it wasn’t alot I didn’t worry too much

Hello Rich,

Thank you for both the helicorders and the logs from the Shake. From them, it appears that there are some data transmission problems that could result in the issue that you are experiencing. Here is a sample:

2023 041 10:26:51>>	!E‹WDHIЉe QсEMȪQº$QcU!”ªQš
2023 041 10:26:51>>		16239	441
2023 041 10:26:51>>	No Data has been received from the MCU in 12 read attempts.It appears the MCU is not transmitting data.  This is a fatal condition and should be investigated if this condition persists!
2023 041 10:26:51>>	Data has been successfully received, fatal condition resolved.

As you can see, there are errors mixed with some ‘gibberish’ that cannot be successfully interpreted. My first thought would be to check and see if the power supply is delivering a stable voltage between 5.0 and 5.2V and a current of at least 2.5A at all times, as a decrease in power could lead to data services interruption. If you have another Pi power supply that you know is in working condition, please try to exchange the current one with that, and see if the gaps persist, or disappear.

A second check that you can do is to see if all the connections between the sensor, the blue Shake board, and the Pi board are still solid and free from dirt or any other element that could compromise transmission. This is important, in particular, if your Shake is located in an environment where dust or moisture can affect it. You can follow our video guides (Assembly Guide — Instructions on Setting Up Your Raspberry Shake) in reverse to disassemble, check, and then re-assemble the Shake.

I think that the large gaps were in some kind associated with the work that has been done around the garage, especially with the use of high-power tools, but the checks above are worth a look.

Thank you for looking at the logs and seeing this error. When I have some time during the week, family takes priority, I will clean it up and check out the power supply. I am almost positive the power supply is more than ample for the Shake, but I will confirm. I am in agreement that the device may have some dirt/dust on it because of the location and when I reset it there were cobwebs on it. Maybe it’s time for an enclosure :slight_smile: … Project time !!!