Fixed IP Issues

I’m trying to get our Shake 3D set up.

However, logging in using rs.local or raspberryshake.local failed.

Here’s why: The university has virtual LANs, and there is a wired, wifi and fixed IP network.

My workstations and servers are on fixed address. That was bound to fail. I then tried using a laptop on the WiFi and wired networks. No luck there either.

I then decided to try to set the RasberryPi to a fixed address. Unfortunately this has gotten more difficult, since I did this on the RasberryPi at home.

eth0 points to the correct network, but I can’t ping anything.

I edited /etc/networks /etc/network/interfaces and /etc/dhcpcd.conf.

Hello Schamschula, welcome to the community!

Could you please attach the logs from the Shake, so that we can try to see what’s going on in more detail?

In case you don’t know or don’t remember how to do it, they are downloadable from the Raspberry Shake’s web configuration page, accessible entering the rs.local (or the Shake IP) address in your browser, then by clicking on the “Download Logs” button.

Thank you.

That’s the whole point: I can’t get to the web front end, as I can’t reach the RaspberryPI on the network. I currently only have console access.

I’ve had a look at /etc/messages, but didn’t see anything there.

What other logs are we looking for?

When I get back to campus, on Monday, I have one more thing I can try: The default subnet is configured to 192.168.x.x, but the campus network is using 10.x.x.x.

The logs file are multiple, and they are generated and packed together via our API, so they are not immediately available in the inner folders of the OS.

It seems that the issue is definitely to be looked on in the complex architecture that your university has. It is worth trying the other subnet before doing anything else.

Please let us know how that test goes.

I tried to change back to DHCP within the virtual LAN in
/etc/networks
/etc/network/interfaces
/etc/dhcpcd.conf

The network is 10.224.x.x
Netmask 255.255.128.0
Router 10.224.127.254

However, I always get a self assigned IP (169.254.87.58) after I reboot.

hi,

without your log files, and the contents of the /etc/ files you are changing, all we can really do on this side is try our best to make the right suggestions.

please send the log files (in directory /opt/log) and the /etc/ files as well. if you feel there could be sensitive material in any of those, feel free to send them as private messages, not a problem.

as well, since the issue here is getting this to work on your university’s network, perhaps an IT person with knowledge of its details could be of help. as giuseppe indicated, without know all of its intricacies, we are a bit hobbled in giving the best advice here.

thanks,
richard

Sorry about that earlier post! The folks that develop gmic use the same Forum package, and I was updating them progress on a dependent package under MacPorts.

I’ll see if I can copy those log files onto a USB drive tomorrow.

Some info that might help:

  • mDNS doesn’t work very well across VLANs by default, your local network administrator would have to configure this for you
  • please limit manual network configuration to /etc/dhcpcd.conf, sample static IP configuration:
interface eth0
static ip_address=192.168.0.2/24
static routers=192.168.0.1
static domain_name_servers=192.168.0.1

You’ll be able to access the shake through the static IP, but rs.local won’t work without any special intervention by your network admin.

That’s the whole problem. A 192.168.x.x address won’t work as there is no such subnet. It is bound to yield a self-assigned address.

I initially tried the default configuration, while on the same network segment, using DHCP. Under normal circumstances mDNS would work within the same physical net.

I tried backing the static address to this configuration.
As expected I could not connect with my laptop, set to 192.168.0.3, as there is no gateway @ 192.168.0.1.

I pulled the /opt/log and /etc directories.
aamu (3.9 MB)

thanks for the logs. this is how they describe the current situation:

  1. ip address is static, set to 192.168.0.2
  2. DNS server set to 192.168.0.1

but you say the univ. doesn’t have such a sub-net, which is why this doesn’t work.

let’s try to start over:

  1. what does the univ. allow in terms of setting of static IP addresses for devices connected to its network?
  2. or, does the univ. provide a DHCP server that assigns the IP and DNS servers automatically?
  3. if so, how does a device get connected to this server for IP assignation?

(and to be clear, it is not possible to plug your shake into your computer directly, where the Shake will have access to the internet at large, this is not possible. you mentioned something about your PC having IP address 192.168.0.3, which makes me think maybe the Shake is plugged into the computer, or not…)

some questions:

  1. what are the methods that the univ. provides for connecting computers / devices to its network?
  2. does this allow for devices that are not pre-approved by the univ. IT department?
  3. based on the answer to #1, what needs to be done for the Shake to make use of the univ. network resources to get it online? (once we know the answer to #1, we can answer this question.)
  4. and, what is the Shake’s ethernet cable plugged into, exactly? what do you expect it should be plugged into?
  5. is there the possibility of connecting the shake to the wireless network provided by the univ.?

thanks in advance,
richard

  1. We have both static and DHCP addresses. My infrastructure (compute cluster, servers and workstations are all on static addresses - legacy, lots of open addresses).

  2. We have students brining personal hardware, all on DHCP.

  3. As far as DHCP devices go, see my post from two days ago. My laptops (Macs) auto-discover the DHCP server.

The ethernet cable is plugged into the 24 port switch along with my servers and compute cluster, which in turn is connected to the building’s router.

My problem is that I want to assign it a static address in the C class subnet. ifconfig shows that address, but I can’t communicate with the router. I can move my laptop to any open address in that block without any problems (nothing special done to register the laptop with ITS). ITS would have to whitelist a particular IP address for external access, but no such action is required for internal access.

Does the Shake 3D have WiFi? I recall seeing a note not to use the built-in WiFi.

My guess is that I’m missing some basic configuration setting somewhere.