Executing swarm - permission denied

Hi there,
I am installing SWARM and when I type ./swarm.sh to open it I get the message ‘permission denied’. How can I fix this? I have tried with typing sudo first but then get ‘command not found’

Thanks

Hello VS1,

have you tried to launch the command prompt with administrator rights, and from there launch ./swarm.sh?

You might need to type sh ./swarm.sh
Just did this today because I rather not mess with chmod +r just yet

Thanks, I have tried this but still does not work?

Hello VS1,

then you may try with executing chmod +x swarm.sh before launching ./swarm.sh.

This should give the file the necessary permissions. In the case it still doesn’t work, you can try to uninstall SWARM and reinstall it again from scratch (after downloading the latest version here: USGS: Volcano Hazards Program), to eliminate the possibility that some misconfigured file is generating this problem.

If, even after this, you are still getting a Permission Denied error, I encourage you to write to SWARM creators at USGS, explain in detail the issue to them and see if they can provide you with a solution, since it is their proprietary software.

1 Like

This is why I shouldn’t rely on fuzzy Linux memories from years ago. Yes, +x to make the file executable not r!! That’s read.

1 Like