Errors trying to download rsudp

Hello, sorry if this has been posted before but I can’t find it.

I recently bought and got my raspberry shake yesterday and I’ve been trying to download rsudp on my linux machine however I’ve been encountering nonstop errors, most of which I’ve managed to get past but I’m not sure how to fix this, here is the error log:

error: Command "gcc -pthread -B /home/matt/miniconda3/envs/rsudp/compiler_compat -Wl,--sysroot=/ -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC -I/tmp/pip-build-env-pecwkr3x/overlay/lib/python3.7/site-packages/numpy/core/include -Ibuild/src.linux-x86_64-3.7/numpy/distutils/include -I/home/matt/miniconda3/envs/rsudp/include/python3.7m -c obspy/io/gse2/src/GSE_UTI/gse_functions.c -o build/temp.linux-x86_64-cpython-37/obspy/io/gse2/src/GSE_UTI/gse_functions.o -MMD -MF build/temp.linux-x86_64-cpython-37/obspy/io/gse2/src/GSE_UTI/gse_functions.o.d" failed with exit status 127
      [end of output]

  note: This error originates from a subprocess, and is likely not a problem with pip.
  ERROR: Failed building wheel for obspy
Successfully built rsudp
Failed to build obspy
ERROR: Could not build wheels for obspy, which is required to install pyproject.toml-based projects
Something went wrong.
Check the error output and try again.

Any ideas on what I can do?

1 Like

Hello Matt, and welcome to our community!

Regarding your error, it’s the first time I am seeing it, but you can try the following:

  1. Install ObsPy in your environment manually, and then try again with RSUDP installation. You can install it with pip (obspy · PyPI) or with conda (Obspy :: Either of the two should be fine.

  2. If the above doesn’t work, and you still get the same error, I would recommend re-flashing the microSD card with a fresh Pi OS system and then installing Anaconda in place of Miniconda. I have Anaconda for my RSUDP installation, and everything went smoothly both during the compiling of the software and its execution.

For anything else, I remain available.