Error Changing IP Static


I tried to fix IP static in my RS3D through the rs.local without success. I do and reboot but the RS3D mantain the old IP…
There are an alternative way to do it? Maybe through ssh connection?

Any suggestion is welcome,


Hello Mar,

yes, for such cases there is an alternative way of doing it, as this user has also done: New user, static not connecting after setting static ip - #2 by smokie

This is the complete procedure:

SSH into the Shake (guide here: How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake)

Once you’re in, copy and paste these commands (this example is for Cloudflare DNS, but you can put for Google DNS if you want):

sudo echo 'static domain_name_servers=' >> /etc/dhcpcd.conf
sudo service dhcpcd restart

Now make sure those changes took hold:

nano /etc/resolv.conf

The file should look like the following:

# Generated by resolvconf

You should not need to restart, these changes will take effect immediately, but if you want, you can still do it.

Thanks! I should search before asking!

I solved too.
I think part of the problem is sometimes the routers themselves and how they assign IPs, can it be?

Until I have forced it in /etc/dhcpcd.conf there has been no way.

When restarting, the IP is already shown correct

Thanks a lot,


1 Like

You’re welcome, no problem at all!

It is indeed the most frequent issue reported by our users, and we are working to try and solve it. The fact is that there is an almost impossible total count of different modem/routers in the world, and while around ~90% of them works perfectly fine with our Shakes, some others present problems.

There was even one that continued closing the server transmission ports every 5 minutes or so, for some unknown reason that we were unable to understand.

Enjoy your Shake!